summaryrefslogtreecommitdiff
path: root/media-video/subtitleripper/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-video/subtitleripper/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-video/subtitleripper/files')
-rw-r--r--media-video/subtitleripper/files/subtitleripper-0.3.4-glibc210.patch21
-rw-r--r--media-video/subtitleripper/files/subtitleripper-0.3.4-libpng.patch25
-rw-r--r--media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch28
-rw-r--r--media-video/subtitleripper/files/subtitleripper-0.3.4-respect-ldflags.patch28
4 files changed, 102 insertions, 0 deletions
diff --git a/media-video/subtitleripper/files/subtitleripper-0.3.4-glibc210.patch b/media-video/subtitleripper/files/subtitleripper-0.3.4-glibc210.patch
new file mode 100644
index 000000000000..8dc2b24f9f6a
--- /dev/null
+++ b/media-video/subtitleripper/files/subtitleripper-0.3.4-glibc210.patch
@@ -0,0 +1,21 @@
+diff -Naurp subtitleripper-orig/vobsub.c subtitleripper/vobsub.c
+--- subtitleripper-orig/vobsub.c 2003-12-08 03:28:02.000000000 -0600
++++ subtitleripper/vobsub.c 2009-05-30 19:09:13.266973499 -0600
+@@ -56,7 +56,7 @@ extern ssize_t getline(char **, size_t *
+ /* FIXME This should go into a general purpose library or even a
+ separate file. */
+ static ssize_t
+-getline (char **lineptr, size_t *n, FILE *stream)
++get_line (char **lineptr, size_t *n, FILE *stream)
+ {
+ size_t res = 0;
+ int c;
+@@ -753,7 +753,7 @@ vobsub_parse_one_line(vobsub_t *vob, FIL
+ do {
+ size_t line_reserve = 0;
+ char *line = NULL;
+- line_size = getline(&line, &line_reserve, fd);
++ line_size = get_line(&line, &line_reserve, fd);
+ if (line_size < 0) {
+ if (line)
+ free(line);
diff --git a/media-video/subtitleripper/files/subtitleripper-0.3.4-libpng.patch b/media-video/subtitleripper/files/subtitleripper-0.3.4-libpng.patch
new file mode 100644
index 000000000000..e9869b3bd5dd
--- /dev/null
+++ b/media-video/subtitleripper/files/subtitleripper-0.3.4-libpng.patch
@@ -0,0 +1,25 @@
+diff -NrU5 subtitleripper.orig/spudec.c subtitleripper/spudec.c
+--- subtitleripper.orig/spudec.c 2009-05-20 03:06:23.000000000 -0600
++++ subtitleripper/spudec.c 2009-05-20 03:07:47.000000000 -0600
+@@ -34,17 +34,18 @@
+
+ #ifdef _HAVE_ZLIB_
+ #include <zlib.h>
+ #endif
+
++#ifdef _HAVE_PNG_
++#include <png.h>
++#endif
++
+ #ifdef _HAVE_LIB_PPM_
+ #include <netpbm/ppm.h>
+ #endif
+
+-#ifdef _HAVE_PNG_
+-#include "png.h"
+-#endif
+
+ static void spudec_handle_rest(spudec_handle_t *this);
+
+ // read a big endian 16 bit value
+ static inline unsigned int get_be16(const unsigned char *p)
diff --git a/media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch b/media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch
new file mode 100644
index 000000000000..7efe223460fc
--- /dev/null
+++ b/media-video/subtitleripper/files/subtitleripper-0.3.4-linkingorder.patch
@@ -0,0 +1,28 @@
+Index: subtitleripper/Makefile
+===================================================================
+--- subtitleripper.orig/Makefile
++++ subtitleripper/Makefile
+@@ -70,19 +70,19 @@ vobsub2pgm.o: vobsub2pgm.c vobsub.h spud
+ # Target
+ subtitle2pgm: subtitle2pgm.o spudec.o
+ @echo "Linking $@"
+- @$(CC) $(LIBS) $^ -o $@
++ @$(CC) $^ -o $@ $(LIBS)
+
+ subtitle2vobsub: subtitle2vobsub.o vobsub.o
+ @echo "Linking $@"
+- @$(CC) $(LIBS) $^ -o $@
++ @$(CC) $^ -o $@ $(LIBS)
+
+ srttool: srttool.o
+ @echo "Linking $@"
+- @$(CC) $(LIBS) -g $^ -o $@
++ @$(CC) -g $^ -o $@ $(LIBS)
+
+ vobsub2pgm: vobsub2pgm.o vobsub.o spudec.o
+ @echo "Linking $@"
+- @$(CC) $(LIBS) -g $^ -o $@
++ @$(CC) -g $^ -o $@ $(LIBS)
+
+ .PHONY: clean dist rpm
+ clean:
diff --git a/media-video/subtitleripper/files/subtitleripper-0.3.4-respect-ldflags.patch b/media-video/subtitleripper/files/subtitleripper-0.3.4-respect-ldflags.patch
new file mode 100644
index 000000000000..2af11d257929
--- /dev/null
+++ b/media-video/subtitleripper/files/subtitleripper-0.3.4-respect-ldflags.patch
@@ -0,0 +1,28 @@
+Index: subtitleripper/Makefile
+===================================================================
+--- subtitleripper.orig/Makefile
++++ subtitleripper/Makefile
+@@ -70,19 +70,19 @@ vobsub2pgm.o: vobsub2pgm.c vobsub.h spud
+ # Target
+ subtitle2pgm: subtitle2pgm.o spudec.o
+ @echo "Linking $@"
+- @$(CC) $^ -o $@ $(LIBS)
++ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ subtitle2vobsub: subtitle2vobsub.o vobsub.o
+ @echo "Linking $@"
+- @$(CC) $^ -o $@ $(LIBS)
++ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ srttool: srttool.o
+ @echo "Linking $@"
+- @$(CC) -g $^ -o $@ $(LIBS)
++ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ vobsub2pgm: vobsub2pgm.o vobsub.o spudec.o
+ @echo "Linking $@"
+- @$(CC) -g $^ -o $@ $(LIBS)
++ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ .PHONY: clean dist rpm
+ clean: