summaryrefslogtreecommitdiff
path: root/media-video/subliminal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /media-video/subliminal
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'media-video/subliminal')
-rw-r--r--media-video/subliminal/Manifest3
-rw-r--r--media-video/subliminal/subliminal-2.0.5-r3.ebuild82
-rw-r--r--media-video/subliminal/subliminal-9999.ebuild25
3 files changed, 97 insertions, 13 deletions
diff --git a/media-video/subliminal/Manifest b/media-video/subliminal/Manifest
index 4fb3d60ff329..a7b19501ffec 100644
--- a/media-video/subliminal/Manifest
+++ b/media-video/subliminal/Manifest
@@ -2,5 +2,6 @@ AUX subliminal-2.0.5-add-missing-comma.patch 1196 BLAKE2B 1042b22bf4c6f488ada97c
DIST matroska_test_w1_1.zip 184550509 BLAKE2B f111725aa08267661942072c2d4ac019d3d322c4e933aad10afb3aa6f69bb3469114c4400d161e53d8a7618b818b22465177460003804a7ac3e69fa4f4db000d SHA512 f170a8e83dab15228f992b3692330163da2402b8e436c7fa195ac1ecc06cf1eaf1a48d8c99a85c031122c158c2d4006023aae75d5b7805385ba25a6d601cb78f
DIST subliminal-2.0.5-r2.tar.gz 4442435 BLAKE2B ea2139bd61344d6a0cb4b48a2b75cbfd29905adc81bca25a332443725fff80bc03b58704d0e6289d44ddc26104e15744f67acb7e0e4eafae584098b02fb4c007 SHA512 b0f99c6b2fa6bc3860c86592bb428c7b4b34836df7a619b19d69b15532a68b4d05369f724131e120d4b390bd91f430aea442aef72ebc00ae8e3d31a457925eec
EBUILD subliminal-2.0.5-r2.ebuild 2387 BLAKE2B 3166277c1cd80023b54103b8ba9cbf2075e16874f8834c973395403b0da0dd42b3ca015dfd192bfcc14822b3eae7244f50688203e3d97c20b757aba51ae0443f SHA512 66e0facc888f2c58351accd0ca1a792278027dc71327307989ba00afca932270b938477acc133ff7c323a928f051b6bd9010661af99f44ce21ecfd9f4b1c08ef
-EBUILD subliminal-9999.ebuild 2198 BLAKE2B 501b26fe3327c44258dc913318301eb71d2173aedcdd2826a10bc40108ce137e345396d30cdc7d5bac87b97e8f145fb49ef450edcdf0b463482d4ba5e5583be4 SHA512 6c344b91493ffd3f780d35c1e2c42bdc735c2b6307a146054b7f93cf20e7e5203e4a98e5300d798139ad5ffdd91b99690976b92c552f3df6f4c5760333dbbe4a
+EBUILD subliminal-2.0.5-r3.ebuild 2475 BLAKE2B d708951ee24309e97054423de7e2b7061b22f4e33f8ffc9838f2615c64e506221dca712c6d7b5ef25314e2397a357d4fd2e4e5767482dce36299e15742601426 SHA512 fc99a04ea7c6d697e6bc8e77f7f2bf42cd7e5ac8a71dcb984b4ce4496959bef2d6b52f67ba74f54b756d16f69cbcf2ae6a363ecdb7f915670f1f7342bb60f105
+EBUILD subliminal-9999.ebuild 2238 BLAKE2B 5375536b8ea031dba6e0c54edf737f8ba25a8a8caa3fc3b7958181cb36aec20e636b93171f01430528eaf661d25b83e36850646caa211c81b217a27c575d1fc4 SHA512 0279f0d36bbc32f4aaf650f5debb39a03c6044a88eaa494e5e6357d67c01634b4876c90182d1bce6459bac767393060f7ddda2446bb589dffc4f1a5abd267fba
MISC metadata.xml 549 BLAKE2B 296a55c59aad7c1d33e65258eaa0481ed167e1c78fa4fa8273acf83366c7b9365f30136ed7d0ad1b71bbde76aa4d0c5e3da98f375be9ad20b76ee77c835d6947 SHA512 cccd163878caccdee339a2e19f9cd5b0954477e767284c4183f9e589c0b5fe59353dfec14982e6dea83d91fc2f2d66904f8f40a1e69c7abab4a6d6baabfdc0c4
diff --git a/media-video/subliminal/subliminal-2.0.5-r3.ebuild b/media-video/subliminal/subliminal-2.0.5-r3.ebuild
new file mode 100644
index 000000000000..88a4d3d9653b
--- /dev/null
+++ b/media-video/subliminal/subliminal-2.0.5-r3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_REQ_USE='xml(+)'
+COMMIT_ID='dd74383d1cba82829ce720f2e439a65d13ffe7ef'
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to search and download subtitles"
+HOMEPAGE="https://github.com/Diaoul/subliminal https://pypi.org/project/subliminal/"
+SRC_URI="
+ https://github.com/Diaoul/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}-r2.tar.gz
+ test? ( mirror://sourceforge/matroska/test_files/matroska_test_w1_1.zip )
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/appdirs-1.3[${PYTHON_USEDEP}]
+ >=dev-python/babelfish-0.5.2[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup-4.4.0:4[${PYTHON_USEDEP}]
+ >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/click-4.0[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/enzyme-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/guessit-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pysrt-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2012c[${PYTHON_USEDEP}]
+ >=dev-python/rarfile-2.7[compressed,${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.0.0[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ app-arch/unzip
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ >=dev-python/vcrpy-1.6.1[${PYTHON_USEDEP}]
+ )
+"
+
+# Tests don't work in 2.0.5. Recheck in later versions. See Gentoo bug 630114.
+RESTRICT=test
+
+PATCHES=( "${FILESDIR}/${P}-add-missing-comma.patch" )
+
+S="${WORKDIR}/${PN}-${COMMIT_ID}"
+
+python_prepare_all() {
+ # Disable code checkers as they require unavailable dependencies.
+ sed -i -e 's/--\(pep8\|flakes\)//g' pytest.ini || die
+ sed -i -e "s/'pytest-\(pep8\|flakes\)',//g" setup.py || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ if use test; then
+ mkdir -p tests/data/mkv || die
+ ln -s "${WORKDIR}"/test*.mkv tests/data/mkv/ || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/media-video/subliminal/subliminal-9999.ebuild b/media-video/subliminal/subliminal-9999.ebuild
index 95473f3790c2..7c83f3864f02 100644
--- a/media-video/subliminal/subliminal-9999.ebuild
+++ b/media-video/subliminal/subliminal-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
PYTHON_REQ_USE='xml(+)'
@@ -20,32 +20,33 @@ KEYWORDS=""
IUSE="test"
RDEPEND="
- >=dev-python/guessit-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/appdirs-1.3[${PYTHON_USEDEP}]
>=dev-python/babelfish-0.5.2[${PYTHON_USEDEP}]
- >=dev-python/enzyme-0.4.1[${PYTHON_USEDEP}]
>=dev-python/beautifulsoup-4.4.0:4[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0[${PYTHON_USEDEP}]
+ >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
>=dev-python/click-4.0[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
>=dev-python/dogpile-cache-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/enzyme-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/guessit-2.0.1[${PYTHON_USEDEP}]
>=dev-python/pysrt-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/appdirs-1.3[${PYTHON_USEDEP}]
- >=dev-python/rarfile-2.7[compressed,${PYTHON_USEDEP}]
>=dev-python/pytz-2012c[${PYTHON_USEDEP}]
+ >=dev-python/rarfile-2.7[compressed,${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.0.0[${PYTHON_USEDEP}]
virtual/python-futures[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
test? (
app-arch/unzip
- >=dev-python/vcrpy-1.6.1[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
dev-python/pytest-cov[${PYTHON_USEDEP}]
dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
dev-python/sympy[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ >=dev-python/vcrpy-1.6.1[${PYTHON_USEDEP}]
)
"