summaryrefslogtreecommitdiff
path: root/media-video/subliminal/subliminal-2.0.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /media-video/subliminal/subliminal-2.0.5-r1.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'media-video/subliminal/subliminal-2.0.5-r1.ebuild')
-rw-r--r--media-video/subliminal/subliminal-2.0.5-r1.ebuild79
1 files changed, 0 insertions, 79 deletions
diff --git a/media-video/subliminal/subliminal-2.0.5-r1.ebuild b/media-video/subliminal/subliminal-2.0.5-r1.ebuild
deleted file mode 100644
index d17857af0c50..000000000000
--- a/media-video/subliminal/subliminal-2.0.5-r1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-PYTHON_REQ_USE='xml(+)'
-COMMIT_ID='dd74383d1cba82829ce720f2e439a65d13ffe7ef'
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Python library to search and download subtitles"
-HOMEPAGE="https://github.com/Diaoul/subliminal https://pypi.org/project/subliminal/"
-SRC_URI="
- https://github.com/Diaoul/${PN}/archive/${COMMIT_ID}.tar.gz -> ${PF}.tar.gz
- test? ( mirror://sourceforge/matroska/test_files/matroska_test_w1_1.zip )
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/guessit-2.0.1[${PYTHON_USEDEP}]
- >=dev-python/babelfish-0.5.2[${PYTHON_USEDEP}]
- >=dev-python/enzyme-0.4.1[${PYTHON_USEDEP}]
- >=dev-python/beautifulsoup-4.4.0:4[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0[${PYTHON_USEDEP}]
- >=dev-python/click-4.0[${PYTHON_USEDEP}]
- >=dev-python/dogpile-cache-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/pysrt-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/appdirs-1.3[${PYTHON_USEDEP}]
- >=dev-python/rarfile-2.7[compressed,${PYTHON_USEDEP}]
- >=dev-python/pytz-2012c[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- virtual/python-futures[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? (
- app-arch/unzip
- >=dev-python/vcrpy-1.6.1[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- dev-python/sympy[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
- )
-"
-
-# Tests don't work in 2.0.5. Recheck in later versions. See Gentoo bug 630114.
-RESTRICT=test
-
-PATCHES=( "${FILESDIR}/${P}-add-missing-comma.patch" )
-
-S="${WORKDIR}/${PF}"
-
-python_prepare_all() {
- # Disable code checkers as they require unavailable dependencies.
- sed -i -e 's/--\(pep8\|flakes\)//g' pytest.ini || die
- sed -i -e "s/'pytest-\(pep8\|flakes\)',//g" setup.py || die
-
- # Disable unconditional dependency on dev-python/pytest-runner.
- sed -i -e "s|'pytest-runner'||g" setup.py || die
-
- if use test; then
- mkdir -p tests/data/mkv || die
- ln -s "${WORKDIR}"/test*.mkv tests/data/mkv/ || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}