summaryrefslogtreecommitdiff
path: root/media-video/subdownloader/subdownloader-2.0.18-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-video/subdownloader/subdownloader-2.0.18-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-video/subdownloader/subdownloader-2.0.18-r1.ebuild')
-rw-r--r--media-video/subdownloader/subdownloader-2.0.18-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-video/subdownloader/subdownloader-2.0.18-r1.ebuild b/media-video/subdownloader/subdownloader-2.0.18-r1.ebuild
new file mode 100644
index 000000000000..0237c1ee661f
--- /dev/null
+++ b/media-video/subdownloader/subdownloader-2.0.18-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 eutils
+
+DESCRIPTION="GUI application for automatic downloading/uploading of subtitles for videofiles"
+HOMEPAGE="http://www.subdownloader.net/"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${PN}_2.0.18.orig.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-python/kaa-metadata[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_install() {
+ python_fix_shebang "${S}"/run.py
+ insinto /usr/share/"${PN}"
+ doins -r cli FileManagement gui languages locale modules run.py
+ fperms 755 /usr/share/"${PN}"/run.py
+ dosym /usr/share/"${PN}"/run.py /usr/bin/"${PN}"
+ doman subdownloader.1
+ dodoc README ChangeLog
+ doicon gui/images/subdownloader.png
+ domenu subdownloader.desktop
+}