summaryrefslogtreecommitdiff
path: root/media-video/streamdeck-ui/streamdeck-ui-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /media-video/streamdeck-ui/streamdeck-ui-9999.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'media-video/streamdeck-ui/streamdeck-ui-9999.ebuild')
-rw-r--r--media-video/streamdeck-ui/streamdeck-ui-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-video/streamdeck-ui/streamdeck-ui-9999.ebuild b/media-video/streamdeck-ui/streamdeck-ui-9999.ebuild
new file mode 100644
index 000000000000..df568550786c
--- /dev/null
+++ b/media-video/streamdeck-ui/streamdeck-ui-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="A Linux compatible UI for the Elgato Stream Deck"
+HOMEPAGE="https://github.com/timothycrosley/streamdeck-ui"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/timothycrosley/streamdeck-ui.git"
+else
+ COMMIT="9b6678d2d3027963ddac147ee3aeda322ec77f29"
+ SRC_URI="https://github.com/timothycrosley/streamdeck-ui/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pynput[${PYTHON_USEDEP}]
+ dev-python/pyside2[${PYTHON_USEDEP},designer]
+ media-libs/elgato-streamdeck[${PYTHON_USEDEP}]
+ dev-libs/hidapi"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i "s#os.path.dirname(os.path.abspath(__file__))#'/usr/share/streamdeck-ui'#" streamdeck_ui/config.py
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ insinto /usr/share/streamdeck-ui
+ doins streamdeck_ui/logo.png
+ doins -r streamdeck_ui/fonts
+ distutils-r1_src_install
+}