summaryrefslogtreecommitdiff
path: root/media-video/rav1e/rav1e-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /media-video/rav1e/rav1e-9999.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'media-video/rav1e/rav1e-9999.ebuild')
-rw-r--r--media-video/rav1e/rav1e-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-video/rav1e/rav1e-9999.ebuild b/media-video/rav1e/rav1e-9999.ebuild
new file mode 100644
index 000000000000..0136a727b3a0
--- /dev/null
+++ b/media-video/rav1e/rav1e-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2017-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Auto-Generated by cargo-ebuild 0.2.0
+
+EAPI=7
+
+inherit cargo
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/xiph/rav1e.git"
+ inherit git-r3
+fi
+
+DESCRIPTION="The fastest and safest AV1 encoder"
+HOMEPAGE="https://github.com/xiph/rav1e/"
+SRC_URI="$(cargo_crate_uris ${CRATES})"
+RESTRICT="mirror"
+LICENSE="BSD-2"
+SLOT="0"
+
+KEYWORDS=""
+IUSE=""
+
+ASM_DEP=">=dev-lang/nasm-2.14"
+DEPEND="amd64? ( ${ASM_DEP} )"
+RDEPEND=""
+
+src_unpack() {
+ if [[ "${PV}" == *9999* ]]; then
+ git-r3_src_unpack
+ cargo_live_src_unpack
+ fi
+}
+
+src_install() {
+ cargo_src_install --path .
+}