summaryrefslogtreecommitdiff
path: root/media-video/rav1e/rav1e-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
commit0f15659d48c193027158492acb726297501202c5 (patch)
tree5502ba879a78b759da28441d418dbbfe08bd8f03 /media-video/rav1e/rav1e-9999.ebuild
parent93a93e9a3b53c1a73142a305ea1f8136846942ee (diff)
gentoo xmass resync : 25.12.2021
Diffstat (limited to 'media-video/rav1e/rav1e-9999.ebuild')
-rw-r--r--media-video/rav1e/rav1e-9999.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/media-video/rav1e/rav1e-9999.ebuild b/media-video/rav1e/rav1e-9999.ebuild
index 77ee1c7cf11d..a13cb191165c 100644
--- a/media-video/rav1e/rav1e-9999.ebuild
+++ b/media-video/rav1e/rav1e-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 2017-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
CRATES=""
@@ -11,29 +11,29 @@ if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/xiph/rav1e.git"
inherit git-r3
else
- SRC_URI="
- https://github.com/xiph/rav1e/archive/v${PV}.tar.gz -> ${P}.tar.gz
- $(cargo_crate_uris ${CRATES})
- "
- KEYWORDS="~amd64 ~arm64 ~ppc64"
+ SRC_URI="https://github.com/xiph/rav1e/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ $(cargo_crate_uris ${CRATES})"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
fi
DESCRIPTION="The fastest and safest AV1 encoder"
HOMEPAGE="https://github.com/xiph/rav1e/"
-RESTRICT=""
-LICENSE="BSD-2 Apache-2.0 MIT Unlicense"
-SLOT="0"
+LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 ISC MIT UoI-NCSA Unlicense ZLIB"
+SLOT="0"
IUSE="+capi"
-ASM_DEP=">=dev-lang/nasm-2.14"
+ASM_DEP=">=dev-lang/nasm-2.15"
BDEPEND="
amd64? ( ${ASM_DEP} )
capi? ( dev-util/cargo-c )
"
+# Rust
+QA_FLAGS_IGNORED="usr/lib.*/librav1e.* usr/bin/rav1e"
+
src_unpack() {
- if [[ "${PV}" == *9999* ]]; then
+ if [[ ${PV} == *9999* ]]; then
git-r3_src_unpack
cargo_live_src_unpack
else
@@ -50,7 +50,7 @@ src_compile() {
|| die "cargo build failed"
if use capi; then
- cargo cbuild ${args} \
+ cargo cbuild ${args} --target-dir="capi" \
--prefix="/usr" --libdir="/usr/$(get_libdir)" \
--library-type=cdylib \
|| die "cargo cbuild failed"
@@ -59,10 +59,10 @@ src_compile() {
src_install() {
export CARGO_HOME="${ECARGO_HOME}"
- local args=$(usex debug "" --release)
+ local args=$(usex debug --debug "")
if use capi; then
- cargo cinstall $args \
+ cargo cinstall $args --target-dir="capi" \
--prefix="/usr" --libdir="/usr/$(get_libdir)" --destdir="${ED}" \
--library-type=cdylib \
|| die "cargo cinstall failed"