summaryrefslogtreecommitdiff
path: root/media-video/raspberrypi-omxplayer/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-video/raspberrypi-omxplayer/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-video/raspberrypi-omxplayer/files')
-rw-r--r--media-video/raspberrypi-omxplayer/files/Makefile-0_p20160217.patch26
-rw-r--r--media-video/raspberrypi-omxplayer/files/Makefile-0_p20160528.patch26
-rw-r--r--media-video/raspberrypi-omxplayer/files/cross-0_p20160528.patch15
-rw-r--r--media-video/raspberrypi-omxplayer/files/fonts-path.patch15
4 files changed, 82 insertions, 0 deletions
diff --git a/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160217.patch b/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160217.patch
new file mode 100644
index 000000000000..c6f945209b95
--- /dev/null
+++ b/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160217.patch
@@ -0,0 +1,26 @@
+--- omxplayer-9999/Makefile
++++ omxplayer-9999/Makefile
+@@ -2,9 +2,11 @@
+
+ CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
+
+-LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz
++PKGS=freetype2 dbus-1 libavcodec libavutil libavformat libswresample libswscale libpcre
++
++LIBS+=-lrt -lpthread $(shell pkg-config --libs $(PKGS)) -L/opt/vc/lib
+
+-INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include
++INCLUDES+=$(shell pkg-config --cflags $(PKGS)) -I/opt/vc/include -I. -Ilinux
+
+ DIST ?= omxplayer-dist
+
+@@ -51,8 +47,7 @@
+ bash gen_version.sh > version.h
+
+ omxplayer.bin: version $(OBJS)
+- $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvcos -ldbus-1 -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
+- $(STRIP) omxplayer.bin
++ $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) $(LIBS)
+
+ help.h: README.md Makefile
+ awk '/SYNOPSIS/{p=1;print;next} p&&/KEY BINDINGS/{p=0};p' $< \
diff --git a/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160528.patch b/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160528.patch
new file mode 100644
index 000000000000..eb65f5d7ad70
--- /dev/null
+++ b/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160528.patch
@@ -0,0 +1,26 @@
+--- omxplayer-9999/Makefile
++++ omxplayer-9999/Makefile
+@@ -2,9 +2,11 @@
+
+ CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
+
+-LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz
++PKGS=freetype2 dbus-1 libavcodec libavutil libavformat libswresample libswscale libpcre
++
++LIBS+=-lrt -lpthread $(shell pkg-config --libs $(PKGS)) -L/opt/vc/lib
+
+-INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include
++INCLUDES+=$(shell pkg-config --cflags $(PKGS)) -I/opt/vc/include -I. -Ilinux
+
+ DIST ?= omxplayer-dist
+
+@@ -51,8 +47,7 @@
+ bash gen_version.sh > version.h
+
+ omxplayer.bin: version $(OBJS)
+- $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvchostif -lvcos -ldbus-1 -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
+- $(STRIP) omxplayer.bin
++ $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) $(LIBS)
+
+ help.h: README.md Makefile
+ awk '/SYNOPSIS/{p=1;print;next} p&&/KEY BINDINGS/{p=0};p' $< \
diff --git a/media-video/raspberrypi-omxplayer/files/cross-0_p20160528.patch b/media-video/raspberrypi-omxplayer/files/cross-0_p20160528.patch
new file mode 100644
index 000000000000..bd35d6283d21
--- /dev/null
+++ b/media-video/raspberrypi-omxplayer/files/cross-0_p20160528.patch
@@ -0,0 +1,15 @@
+--- a/Makefile
++++ b/Makefile
+@@ -4,9 +4,11 @@
+
+ PKGS=freetype2 dbus-1 libavcodec libavutil libavformat libswresample libswscale libpcre
+
+-LIBS+=-lrt -lpthread $(shell pkg-config --libs $(PKGS)) -L/opt/vc/lib
++PKG_CONFIG ?= pkg-config
+
+-INCLUDES+=$(shell pkg-config --cflags $(PKGS)) -I/opt/vc/include -I. -Ilinux
++LIBS+=-lrt -lpthread $(shell $(PKG_CONFIG) --libs $(PKGS)) -L${SYSROOT}/opt/vc/lib
++
++INCLUDES+=$(shell $(PKG_CONFIG) --cflags $(PKGS)) -I${SYSROOT}/opt/vc/include -I. -Ilinux
+
+ DIST ?= omxplayer-dist
diff --git a/media-video/raspberrypi-omxplayer/files/fonts-path.patch b/media-video/raspberrypi-omxplayer/files/fonts-path.patch
new file mode 100644
index 000000000000..6683145f6833
--- /dev/null
+++ b/media-video/raspberrypi-omxplayer/files/fonts-path.patch
@@ -0,0 +1,15 @@
+diff --git a/omxplayer.cpp b/omxplayer.cpp
+index 0626e2e..8450bf2 100644
+--- a/omxplayer.cpp
++++ b/omxplayer.cpp
+@@ -83,8 +83,8 @@ bool m_osd = true;
+ bool m_no_keys = false;
+ std::string m_external_subtitles_path;
+ bool m_has_external_subtitles = false;
+-std::string m_font_path = "/usr/share/fonts/truetype/freefont/FreeSans.ttf";
+-std::string m_italic_font_path = "/usr/share/fonts/truetype/freefont/FreeSansOblique.ttf";
++std::string m_font_path = "/usr/share/fonts/freefont/FreeSans.ttf";
++std::string m_italic_font_path = "/usr/share/fonts/freefont/FreeSansOblique.ttf";
+ std::string m_dbus_name = "org.mpris.MediaPlayer2.omxplayer";
+ bool m_asked_for_font = false;
+ bool m_asked_for_italic_font = false;