summaryrefslogtreecommitdiff
path: root/media-video/plasma-mediacenter/plasma-mediacenter-5.7.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-video/plasma-mediacenter/plasma-mediacenter-5.7.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-video/plasma-mediacenter/plasma-mediacenter-5.7.5.ebuild')
-rw-r--r--media-video/plasma-mediacenter/plasma-mediacenter-5.7.5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-video/plasma-mediacenter/plasma-mediacenter-5.7.5.ebuild b/media-video/plasma-mediacenter/plasma-mediacenter-5.7.5.ebuild
new file mode 100644
index 000000000000..81d5579d3d99
--- /dev/null
+++ b/media-video/plasma-mediacenter/plasma-mediacenter-5.7.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Unified media experience for any device capable of running KDE Plasma"
+SRC_URI="mirror://kde/stable/plasma-mediacenter/${PV}/${P}.tar.xz"
+KEYWORDS="amd64 ~arm x86"
+IUSE="semantic-desktop"
+
+DEPEND="
+ $(add_frameworks_dep kactivities)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtxml)
+ media-libs/taglib
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep plasma-workspace)
+ $(add_qt_dep qtmultimedia 'qml')
+ !media-video/plasma-mediacenter:0
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetadata)
+ )
+
+ kde5_src_configure
+}