summaryrefslogtreecommitdiff
path: root/media-video/pitivi/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /media-video/pitivi/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'media-video/pitivi/files')
-rw-r--r--media-video/pitivi/files/pitivi-0.999-metainfo.patch12
-rw-r--r--media-video/pitivi/files/pitivi-0.999-python38.patch49
2 files changed, 61 insertions, 0 deletions
diff --git a/media-video/pitivi/files/pitivi-0.999-metainfo.patch b/media-video/pitivi/files/pitivi-0.999-metainfo.patch
new file mode 100644
index 000000000000..830a246e60dd
--- /dev/null
+++ b/media-video/pitivi/files/pitivi-0.999-metainfo.patch
@@ -0,0 +1,12 @@
+diff --unified --new-file --recursive --show-c-function '--color=auto' pitivi-0.999/data/meson.build pitivi-0.999-fix/data/meson.build
+--- pitivi-0.999/data/meson.build 2018-08-29 16:05:21.000000000 +0200
++++ pitivi-0.999-fix/data/meson.build 2021-04-18 09:10:56.067231216 +0200
+@@ -18,7 +18,7 @@ custom_target('org.pitivi.Pitivi.appdata
+ input : 'org.pitivi.Pitivi.appdata.xml.in',
+ command : [intltool_merge, '--xml-style', podir, '@INPUT@', '@OUTPUT@'],
+ install : true,
+- install_dir : join_paths(get_option('datadir'), 'appdata'))
++ install_dir : join_paths(get_option('datadir'), 'metainfo'))
+
+ install_data('org.pitivi.Pitivi-mime.xml',
+ install_dir : join_paths(get_option('datadir'), 'mime/packages'))
diff --git a/media-video/pitivi/files/pitivi-0.999-python38.patch b/media-video/pitivi/files/pitivi-0.999-python38.patch
new file mode 100644
index 000000000000..3c240d949112
--- /dev/null
+++ b/media-video/pitivi/files/pitivi-0.999-python38.patch
@@ -0,0 +1,49 @@
+From 3c2c03828efb986e66ba2a35e341127e8161c799 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Alexandru=20B=C4=83lu=C8=9B?= <alexandru.balut@gmail.com>
+Date: Tue, 28 Jan 2020 22:34:40 +0100
+Subject: [PATCH] meson: Support Python 3.8
+
+To link to Python we need to use python-3.8-embed.
+---
+ meson.build | 13 ++++++++++---
+ meson_options.txt | 3 ++-
+ 2 files changed, 12 insertions(+), 4 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 17a7312d..289e0086 100644
+--- a/meson.build
++++ b/meson.build
+@@ -1,11 +1,18 @@
+-project('pitivi', 'c', version : '0.999', meson_version : '>= 0.41.0')
++project('pitivi', 'c', version : '0.999', meson_version : '>= 0.46.0')
+
+-python = find_program('python3')
+ intltool_merge = find_program('intltool-merge')
+ itstool = find_program('itstool')
+ msgfmt = find_program('msgfmt')
+
+-python_dep = dependency('python3', version : '>= 3.3')
++pymod = import('python')
++python = pymod.find_installation(get_option('python'))
++pythonver = python.language_version()
++# Workaround for https://github.com/mesonbuild/meson/issues/5629
++# https://gitlab.freedesktop.org/gstreamer/gst-python/issues/28
++python_dep = dependency('python-@0@-embed'.format(pythonver), version: '>= 3.3', required: false)
++if not python_dep.found()
++ python_dep = python.dependency('python3', version: '>= 3.3')
++endif
+
+ if get_option('build-gst')
+ subproject('gst-build', default_options: ['enable_python=true',
+diff --git a/meson_options.txt b/meson_options.txt
+index c6590dd1..7d6bad29 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -1,2 +1,3 @@
+-option('disable-help', type : 'boolean', value : false)
+ option('build-gst', type : 'boolean', value : false)
++option('disable-help', type : 'boolean', value : false)
++option('python', type : 'string', value : 'python3')
+--
+2.26.2
+