summaryrefslogtreecommitdiff
path: root/media-video/pitivi/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /media-video/pitivi/files
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'media-video/pitivi/files')
-rw-r--r--media-video/pitivi/files/pitivi-2021.05-meson-compatibility.patch45
-rw-r--r--media-video/pitivi/files/pitivi-2021.05-python-collections.patch13
2 files changed, 58 insertions, 0 deletions
diff --git a/media-video/pitivi/files/pitivi-2021.05-meson-compatibility.patch b/media-video/pitivi/files/pitivi-2021.05-meson-compatibility.patch
new file mode 100644
index 000000000000..990f84b06795
--- /dev/null
+++ b/media-video/pitivi/files/pitivi-2021.05-meson-compatibility.patch
@@ -0,0 +1,45 @@
+From ddf2369d1fc6fddd63f676cc905a8b8e96291a4c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Sebastian=20Dr=C3=B6ge?= <sebastian@centricular.com>
+Date: Tue, 25 Jan 2022 15:37:34 +0200
+Subject: [PATCH] Fix compatibility with meson 0.61
+
+Previously positional arguments to i18n.merge_files() were just ignored
+but this became an error.
+---
+ data/meson.build | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/data/meson.build b/data/meson.build
+index 2ea82cf12..60d23169b 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -6,7 +6,7 @@ install_subdir('audiopresets', install_dir: pkgdatadir)
+ install_subdir('videopresets', install_dir: pkgdatadir)
+ install_subdir('gstpresets', install_dir: pkgdatadir)
+
+-desktop_file = i18n.merge_file('org.pitivi.Pitivi.desktop',
++desktop_file = i18n.merge_file(
+ type: 'desktop',
+ output : 'org.pitivi.Pitivi.desktop',
+ input : 'org.pitivi.Pitivi.desktop.in',
+@@ -25,7 +25,7 @@ if desktop_file_validate.found()
+ )
+ endif
+
+-appdata_file = i18n.merge_file('org.pitivi.Pitivi.appdata.xml',
++appdata_file = i18n.merge_file(
+ type: 'xml',
+ output : 'org.pitivi.Pitivi.appdata.xml',
+ input : 'org.pitivi.Pitivi.appdata.xml.in',
+@@ -43,7 +43,7 @@ if appstream_util.found()
+ )
+ endif
+
+-i18n.merge_file('org.pitivi.Pitivi-mime.xml',
++i18n.merge_file(
+ output : 'org.pitivi.Pitivi-mime.xml',
+ input : 'org.pitivi.Pitivi-mime.xml.in',
+ po_dir: podir,
+--
+GitLab
+
diff --git a/media-video/pitivi/files/pitivi-2021.05-python-collections.patch b/media-video/pitivi/files/pitivi-2021.05-python-collections.patch
new file mode 100644
index 000000000000..fc04cd8d8726
--- /dev/null
+++ b/media-video/pitivi/files/pitivi-2021.05-python-collections.patch
@@ -0,0 +1,13 @@
+https://src.fedoraproject.org/rpms/pitivi/raw/rawhide/f/collections.patch
+--- a/pitivi/utils/loggable.py
++++ b/pitivi/utils/loggable.py
+@@ -14,7 +14,7 @@
+ #
+ # You should have received a copy of the GNU Lesser General Public
+ # License along with this program; if not, see <http://www.gnu.org/licenses/>.
+-import collections
++import collections.abc as collections
+ import errno
+ import fnmatch
+ import os
+