summaryrefslogtreecommitdiff
path: root/media-video/pipewire/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /media-video/pipewire/files
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'media-video/pipewire/files')
-rw-r--r--media-video/pipewire/files/pipewire-0.3.38-find-readline.patch36
-rw-r--r--media-video/pipewire/files/pipewire-0.3.38-fix-arm-build.patch18
-rw-r--r--media-video/pipewire/files/pipewire-0.3.38-libcamera-null-deref.patch70
3 files changed, 0 insertions, 124 deletions
diff --git a/media-video/pipewire/files/pipewire-0.3.38-find-readline.patch b/media-video/pipewire/files/pipewire-0.3.38-find-readline.patch
deleted file mode 100644
index 6b56304f5d17..000000000000
--- a/media-video/pipewire/files/pipewire-0.3.38-find-readline.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-https://gitlab.freedesktop.org/pipewire/pipewire/-/commit/ddfbd684e78e2b8b9ad40bedb4612ea0197d231a.patch
-
-From: Joshua Strobl <joshua@streambits.io>
-Date: Thu, 30 Sep 2021 23:11:50 +0300
-Subject: [PATCH] Fix readline detection by allowing fallback to cc
- find_library
-
---- a/meson.build
-+++ b/meson.build
-@@ -326,6 +326,11 @@ dbus_dep = dependency('dbus-1')
- sdl_dep = dependency('sdl2', required : get_option('sdl2'))
- summary({'SDL 2': sdl_dep.found()}, bool_yn: true, section: 'Misc dependencies')
- readline_dep = dependency('readline', required : false)
-+
-+if not readline_dep.found()
-+ readline_dep = cc.find_library('readline', required: false)
-+endif
-+
- summary({'readline (for pw-cli)': readline_dep.found()}, bool_yn: true, section: 'Misc dependencies')
- ncurses_dep = dependency('ncursesw', required : false)
- sndfile_dep = dependency('sndfile', version : '>= 1.0.20', required : get_option('sndfile'))
-@@ -406,7 +411,12 @@ libinotify_dep = (build_machine.system() == 'freebsd'
- : dependency('', required: false))
-
- # On FreeBSD, libintl library is required for gettext
--libintl_dep = cc.find_library('intl', required: false)
-+libintl_dep = dependency('intl', required: false)
-+
-+if not libintl_dep.found()
-+ libintl_dep = cc.find_library('intl', required: false)
-+endif
-+summary({'intl support': libintl_dep.found()}, bool_yn: true)
-
- need_alsa = get_option('pipewire-alsa').enabled() or get_option('session-managers').contains('media-session')
- alsa_dep = dependency('alsa', version : '>=1.1.7', required: need_alsa)
-GitLab
diff --git a/media-video/pipewire/files/pipewire-0.3.38-fix-arm-build.patch b/media-video/pipewire/files/pipewire-0.3.38-fix-arm-build.patch
deleted file mode 100644
index 222aa58cce13..000000000000
--- a/media-video/pipewire/files/pipewire-0.3.38-fix-arm-build.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-https://gitlab.freedesktop.org/pipewire/pipewire/-/commit/f8817b439433798bd7217dc4ae72197887b0fc96.patch
-
-From: Wim Taymans <wtaymans@redhat.com>
-Date: Thu, 30 Sep 2021 11:12:27 +0200
-Subject: [PATCH] cpu: fix compilation on ARM
-
---- a/spa/plugins/support/cpu-arm.c
-+++ b/spa/plugins/support/cpu-arm.c
-@@ -80,7 +80,7 @@ arm_init(struct impl *impl)
- int arch;
-
- if (!(cpuinfo = get_cpuinfo())) {
-- spa_log_warn(impl->log, NAME " %p: Can't read cpuinfo", impl);
-+ spa_log_warn(impl->log, "%p: Can't read cpuinfo", impl);
- return 1;
- }
-
-GitLab
diff --git a/media-video/pipewire/files/pipewire-0.3.38-libcamera-null-deref.patch b/media-video/pipewire/files/pipewire-0.3.38-libcamera-null-deref.patch
deleted file mode 100644
index beabd1a30291..000000000000
--- a/media-video/pipewire/files/pipewire-0.3.38-libcamera-null-deref.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-https://gitlab.freedesktop.org/pipewire/pipewire/-/commit/d71a10b7fa9b5c560485b6bbde409c10d3fdd114.patch
-
-From: Wim Taymans <wtaymans@redhat.com>
-Date: Thu, 30 Sep 2021 12:54:29 +0200
-Subject: [PATCH] libcamera: handle failure gracefully
-
-Don't try to access NULL pointers
---- a/spa/plugins/libcamera/libcamera-client.c
-+++ b/spa/plugins/libcamera/libcamera-client.c
-@@ -210,10 +210,10 @@ impl_init(const struct spa_handle_factory *factory,
- SPA_DEVICE_CHANGE_MASK_PROPS;
- this->info.flags = 0;
-
-- if(this->dev.camera == NULL) {
-+ if(this->dev.camera == NULL)
- this->dev.camera = (LibCamera*)newLibCamera();
-+ if(this->dev.camera != NULL)
- libcamera_set_log(this->dev.camera, this->dev.log);
-- }
-
- return 0;
- }
---- a/spa/plugins/libcamera/libcamera-source.c
-+++ b/spa/plugins/libcamera/libcamera-source.c
-@@ -994,10 +994,10 @@ impl_init(const struct spa_handle_factory *factory,
- port->dev.log = this->log;
- port->dev.fd = -1;
-
-- if(port->dev.camera == NULL) {
-+ if(port->dev.camera == NULL)
- port->dev.camera = (LibCamera*)newLibCamera();
-+ if(port->dev.camera != NULL)
- libcamera_set_log(port->dev.camera, port->dev.log);
-- }
-
- if (info && (str = spa_dict_lookup(info, SPA_KEY_API_LIBCAMERA_PATH))) {
- strncpy(this->props.device, str, 63);
---- a/spa/plugins/libcamera/libcamera_wrapper.cpp
-+++ b/spa/plugins/libcamera/libcamera_wrapper.cpp
-@@ -540,7 +540,8 @@ extern "C" {
- }
-
- void LibCamera::close() {
-- this->cam_->release();
-+ if (this->cam_)
-+ this->cam_->release();
- }
-
- void LibCamera::connect()
-@@ -775,6 +776,9 @@ extern "C" {
- std::unique_ptr<CameraManager> cm = std::make_unique<CameraManager>();
- LibCamera* camera = new LibCamera();
-
-+ pthread_mutexattr_init(&attr);
-+ pthread_mutex_init(&camera->lock, &attr);
-+
- ret = cm->start();
- if (ret) {
- deleteLibCamera(camera);
-@@ -794,9 +798,6 @@ extern "C" {
- return nullptr;
- }
-
-- pthread_mutexattr_init(&attr);
-- pthread_mutex_init(&camera->lock, &attr);
--
- camera->ring_buffer_init();
-
- return camera;
-GitLab