summaryrefslogtreecommitdiff
path: root/media-video/obs-studio/obs-studio-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-video/obs-studio/obs-studio-9999.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-video/obs-studio/obs-studio-9999.ebuild')
-rw-r--r--media-video/obs-studio/obs-studio-9999.ebuild28
1 files changed, 9 insertions, 19 deletions
diff --git a/media-video/obs-studio/obs-studio-9999.ebuild b/media-video/obs-studio/obs-studio-9999.ebuild
index 6e23d6b2b473..b9550e6de3df 100644
--- a/media-video/obs-studio/obs-studio-9999.ebuild
+++ b/media-video/obs-studio/obs-studio-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,8 +9,8 @@ PYTHON_COMPAT=( python3_{8..10} )
inherit cmake lua-single python-single-r1 xdg
-OBS_BROWSER_COMMIT="2a338b7c76d5dd0a6b23f1d49affefd40213b0e9"
-CEF_DIR="cef_binary_4280_linux64"
+OBS_BROWSER_COMMIT="915761778ec1eae99e740ad4bf63b40db3142ee2"
+CEF_DIR="cef_binary_4638_linux64"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -58,9 +58,10 @@ DEPEND="
dev-qt/qtxml:5
media-libs/libglvnd
media-libs/x264:=
- media-video/ffmpeg:=[x264]
+ media-video/ffmpeg:=[nvenc?,x264]
net-misc/curl
sys-apps/dbus
+ sys-apps/pciutils
sys-libs/zlib:=
virtual/udev
x11-libs/libX11
@@ -82,6 +83,7 @@ DEPEND="
media-libs/fontconfig
media-libs/mesa[gbm(+)]
net-print/cups
+ x11-libs/cairo
x11-libs/libdrm
x11-libs/libXScrnSaver
x11-libs/libXcursor
@@ -94,7 +96,6 @@ DEPEND="
fdk? ( media-libs/fdk-aac:= )
jack? ( virtual/jack )
lua? ( ${LUA_DEPS} )
- nvenc? ( >=media-video/ffmpeg-4[video_cards_nvidia] )
pipewire? ( media-video/pipewire:= )
pulseaudio? ( media-sound/pulseaudio )
python? ( ${PYTHON_DEPS} )
@@ -112,17 +113,15 @@ RDEPEND="${DEPEND}"
QA_PREBUILT="
usr/lib*/obs-plugins/chrome-sandbox
+ usr/lib*/obs-plugins/libcef.so
usr/lib*/obs-plugins/libEGL.so
usr/lib*/obs-plugins/libGLESv2.so
- usr/lib*/obs-plugins/libcef.so
+ usr/lib*/obs-plugins/libvk_swiftshader.so
+ usr/lib*/obs-plugins/libvulkan.so.1
usr/lib*/obs-plugins/swiftshader/libEGL.so
usr/lib*/obs-plugins/swiftshader/libGLESv2.so
"
-PATCHES=(
- "${FILESDIR}/${PN}-26.1.2-python-3.8.patch"
-)
-
pkg_setup() {
use lua && lua-single_pkg_setup
use python && python-single-r1_pkg_setup
@@ -153,7 +152,6 @@ src_configure() {
-DDISABLE_LIBFDK=$(usex !fdk)
-DENABLE_PIPEWIRE=$(usex pipewire)
-DDISABLE_PULSEAUDIO=$(usex !pulseaudio)
- $(cmake_use_find_package pulseaudio PulseAudio)
-DDISABLE_SPEEXDSP=$(usex !speex)
-DDISABLE_V4L2=$(usex !v4l)
-DDISABLE_VLC=$(usex !vlc)
@@ -203,12 +201,4 @@ pkg_postinst() {
elog "be enabled."
elog
fi
-
- if use python; then
- ewarn "This ebuild applies a patch that is not yet accepted upstream,"
- ewarn "and while it fixes Python support at least to some extent, it"
- ewarn "may cause other issues."
- ewarn ""
- ewarn "Please report any such issues to the Gentoo maintainer."
- fi
}