summaryrefslogtreecommitdiff
path: root/media-video/mpv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-03 07:33:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-03 07:33:54 +0000
commit84d7c5e06639a9bcbf66ae744833b34422e478a6 (patch)
tree48da2d9483d2a87f954b8c4cf7c2024f2c773e45 /media-video/mpv
parent92b7880bd28edc591d46c65b2242bbad6106fb39 (diff)
gentoo auto-resync : 03:03:2023 - 07:33:53
Diffstat (limited to 'media-video/mpv')
-rw-r--r--media-video/mpv/Manifest2
-rw-r--r--media-video/mpv/mpv-9999.ebuild25
2 files changed, 2 insertions, 25 deletions
diff --git a/media-video/mpv/Manifest b/media-video/mpv/Manifest
index 29e53cf82141..efc492ca0e9b 100644
--- a/media-video/mpv/Manifest
+++ b/media-video/mpv/Manifest
@@ -5,5 +5,5 @@ DIST waf-2.0.22 104880 BLAKE2B 6cae9e764712012ef97f790c723b86a2603dc64e9bafcec02
EBUILD mpv-0.34.1-r1.ebuild 9733 BLAKE2B 0edc617690adea48d4cd253a28aa56906684a55272630a9163b2573887afad4fd288bd9db72133494ac9cb58cb9415b9195415d61671430e4a1c19f63e833df3 SHA512 8710249d67c5c48dc4c9788ad8e0fef7a6ace8b52306da1b900a3098227115c547ed3b86b2389c32798df3d13bfa7a458303d8e0266258ffc205f7387823572b
EBUILD mpv-0.35.0-r1.ebuild 7715 BLAKE2B 697a5320c5f572b7932894656313661c99d0ccc8824ba40d23de535824ae4a48ba93dc34f64f341e901f190a5fa8d32b8303839bb10eab9f7a9891da899180ad SHA512 6bb601e58c4c5cbc161d6dc71f253557c17359d7c1bb0505d0db407fda2b259c519cd98eb268608ba8054034c2ff9312596505044c1d75d85b3d51160da73e1f
EBUILD mpv-0.35.1.ebuild 7523 BLAKE2B 7fc73d01058aaddab3708b04730cd0bc9485111212245450d2036e46eaa518423c2023da427553f3f09d539fd4837ed61db9de7abd3ed03fa36a1cbf32775c7f SHA512 99decef6d6f899b259deb7f304ef05b66c5f9983adb7d2f55fc6b8294f3ff332a5e000d5f8c2d087e43dbc2329bc13f1b6417e787b596c3cb843b4e199c6781c
-EBUILD mpv-9999.ebuild 7630 BLAKE2B 8a7516a74dabe4ed0378ae6707df6c6c4be9f48c7f7e350de7e2109740b940d8a8983ba95d54a70e390fb9fccf6909bff82faaa2c2569a1b43b556e7a2a4e67d SHA512 27383e73d826c14cb330647c293c221f187d382866782ad7c7b2225e36ecaa9a612acda2812f22e4caff3953c4650edd64bb2a0daada0b818a641df69432f7e9
+EBUILD mpv-9999.ebuild 7013 BLAKE2B f1a7f7bebd38ef06b455c16bf8be0bfeb4cd050d805ecffb9c9d5445e15c82ba766be6995b8503582568b8c708c0051081ae4db367a5c0f984f063a22b022bb8 SHA512 6e53676790a99b5c6610747fcc652962aacb79b18df2db905e4483ec8c7f7f149bf6f3757b8f98ad36fa8364dc22e8ab639ccd71a51f65e8fecec4d63a784767
MISC metadata.xml 2537 BLAKE2B ce08ff18966b0937d5c1564a32d8da1225d603626d02b081f8a236531683890770d134fb7898a208bceffeb7ed2d1cabf34f4d211a97d1d0d95287830b93ddbc SHA512 5dc6cdacffed6f751a05d261a23e765cf3eaa16bd0757853635da977176666f5fc75f0a6c759ccbfcfdd63c2732a0b53858f0379d5f3437bcd9b40a7cb82f59c
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 34293c859ac9..74cbb75b987a 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
LUA_COMPAT=( lua5-1 luajit )
PYTHON_COMPAT=( python3_{9..11} )
-inherit edo flag-o-matic lua-single meson optfeature pax-utils python-single-r1 xdg
+inherit flag-o-matic lua-single meson optfeature pax-utils python-single-r1 xdg
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -243,29 +243,6 @@ src_configure() {
meson_src_configure
}
-src_test() {
- # https://github.com/mpv-player/mpv/blob/master/DOCS/man/options.rst#debugging
- local tests=($("${BUILD_DIR}"/mpv --no-config --unittest=help | tail -n +2; assert))
- (( ${#tests[@]} )) || die "failed to gather any tests"
-
- local skip=(
- all-simple
-
- # fails on non-issue minor inconsistencies (bug #888639)
- img_format
- repack_sws
- )
-
- local test
- for test in "${tests[@]}"; do
- [[ ${test} == @($(IFS='|'; echo "${skip[*]}")) ]] ||
- edo "${BUILD_DIR}"/mpv -v --no-config --unittest="${test}"
- done
-
- # currently only does basic libmpv testing, do in addition to --unittest
- meson_src_test
-}
-
src_install() {
meson_src_install