summaryrefslogtreecommitdiff
path: root/media-video/mpv/mpv-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /media-video/mpv/mpv-9999.ebuild
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'media-video/mpv/mpv-9999.ebuild')
-rw-r--r--media-video/mpv/mpv-9999.ebuild43
1 files changed, 18 insertions, 25 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index c530dace68b4..e273db3d080b 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -8,7 +8,7 @@ PYTHON_REQ_USE='threads(+)'
WAF_PV=1.9.8
-inherit flag-o-matic gnome2-utils pax-utils python-r1 toolchain-funcs versionator waf-utils xdg-utils
+inherit eapi7-ver flag-o-matic gnome2-utils pax-utils python-r1 toolchain-funcs waf-utils xdg-utils
DESCRIPTION="Media player based on MPlayer and mplayer2"
HOMEPAGE="https://mpv.io/"
@@ -20,6 +20,7 @@ if [[ ${PV} != *9999* ]]; then
else
EGIT_REPO_URI="https://github.com/mpv-player/mpv.git"
inherit git-r3
+ DOCS=(); SRC_URI=""
fi
SRC_URI+=" https://waf.io/waf-${WAF_PV}"
DOCS+=( README.md DOCS/{client-api,interface}-changes.rst )
@@ -134,10 +135,6 @@ PATCHES=(
"${FILESDIR}/${PN}-0.19.0-make-ffmpeg-version-check-non-fatal.patch"
)
-pkg_setup() {
- [[ ${MERGE_TYPE} != "binary" ]] && python_setup
-}
-
src_prepare() {
cp "${DISTDIR}/waf-${WAF_PV}" "${S}"/waf || die
chmod +x "${S}"/waf || die
@@ -145,6 +142,7 @@ src_prepare() {
}
src_configure() {
+ python_setup
tc-export CC PKG_CONFIG AR
if use raspberry-pi; then
@@ -163,8 +161,8 @@ src_configure() {
--disable-libmpv-static
--disable-static-build
# See deep down below for build-date.
- --disable-optimize # Don't add '-O2' to CFLAGS.
- --disable-debug-build # Don't add '-g' to CFLAGS.
+ --disable-optimize # Don't add '-O2' to CFLAGS.
+ --disable-debug-build # Don't add '-g' to CFLAGS.
--enable-html-build
$(use_enable doc pdf-build)
@@ -189,18 +187,17 @@ src_configure() {
$(use_enable uchardet)
$(use_enable rubberband)
$(use_enable lcms lcms2)
- --disable-vapoursynth # Only available in overlays.
+ --disable-vapoursynth # Only available in overlays.
--disable-vapoursynth-lazy
$(use_enable archive libarchive)
--enable-libavdevice
# Audio outputs:
- $(use_enable sdl sdl2) # Listed under audio, but also includes video.
- --disable-sdl1
+ $(use_enable sdl sdl2) # Listed under audio, but also includes video.
$(use_enable oss oss-audio)
- --disable-rsound # Only available in overlays.
- --disable-sndio # Only available in overlays.
+ --disable-rsound # Only available in overlays.
+ --disable-sndio # Only available in overlays.
$(use_enable pulseaudio pulse)
$(use_enable jack)
$(use_enable openal)
@@ -224,7 +221,7 @@ src_configure() {
$(usex opengl "$(use_enable wayland gl-wayland)" '--disable-gl-wayland')
$(use_enable vdpau)
$(usex vdpau "$(use_enable opengl vdpau-gl-x11)" '--disable-vdpau-gl-x11')
- $(use_enable vaapi) # See below for vaapi-glx, vaapi-x-egl.
+ $(use_enable vaapi) # See below for vaapi-glx, vaapi-x-egl.
$(usex vaapi "$(use_enable X vaapi-x11)" '--disable-vaapi-x11')
$(usex vaapi "$(use_enable wayland vaapi-wayland)" '--disable-vaapi-wayland')
$(usex vaapi "$(use_enable gbm vaapi-drm)" '--disable-vaapi-drm')
@@ -232,7 +229,7 @@ src_configure() {
$(use_enable jpeg)
$(use_enable raspberry-pi rpi)
$(usex libmpv "$(use_enable opengl plain-gl)" '--disable-plain-gl')
- --disable-mali-fbdev # Only available in overlays.
+ --disable-mali-fbdev # Only available in overlays.
$(usex opengl '' '--disable-gl')
# HWaccels:
@@ -247,7 +244,7 @@ src_configure() {
$(use_enable dvb dvbin)
# Miscellaneous features:
- --disable-apple-remote # Needs testing first. See Gentoo bug 577332.
+ --disable-apple-remote # Needs testing first. See Gentoo bug 577332.
)
if use vaapi && use X; then
@@ -286,14 +283,10 @@ pkg_postinst() {
local rv softvol_0_18_1=0 osc_0_21_0=0 txtsubs_0_24_0=0 opengl_0_25_0=0
for rv in ${REPLACING_VERSIONS}; do
- version_compare ${rv} 0.18.1
- [[ $? -eq 1 ]] && softvol_0_18_1=1
- version_compare ${rv} 0.21.0
- [[ $? -eq 1 ]] && osc_0_21_0=1
- version_compare ${rv} 0.24.0
- [[ $? -eq 1 ]] && txtsubs_0_24_0=1
- version_compare ${rv} 0.25.0
- [[ $? -eq 1 ]] && ! use opengl && opengl_0_25_0=1
+ ver_test ${rv} -lt 0.18.1 && softvol_0_18_1=1
+ ver_test ${rv} -lt 0.21.0 && osc_0_21_0=1
+ ver_test ${rv} -lt 0.24.0 && txtsubs_0_24_0=1
+ ver_test ${rv} -lt 0.25.0 && ! use opengl && opengl_0_25_0=1
done
if [[ ${softvol_0_18_1} -eq 1 ]]; then
@@ -333,8 +326,8 @@ pkg_postinst() {
elog "please install app-shells/mpv-bash-completion."
fi
- if use cli && [[ -n ${REPLACING_VERSIONS} ]] && \
- has_version 'app-shells/mpv-bash-completion'; then
+ if use cli && [[ -n ${REPLACING_VERSIONS} ]] &&
+ has_version 'app-shells/mpv-bash-completion'; then
elog "If command-line completion doesn't work after mpv update,"
elog "please rebuild app-shells/mpv-bash-completion."
fi