summaryrefslogtreecommitdiff
path: root/media-video/mpv/mpv-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
commit51536d2fe4697ba9114d611178bb9e20d3d5b729 (patch)
tree30b91d98e65985a575940ed49e756697c1f049c2 /media-video/mpv/mpv-9999.ebuild
parent4ab6db5717ef23f29320d4c6fb9ebdb8dec1f193 (diff)
gentoo resync : 23.12.2017
Diffstat (limited to 'media-video/mpv/mpv-9999.ebuild')
-rw-r--r--media-video/mpv/mpv-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 32de4217994a..1543eb4db2e5 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -93,11 +93,12 @@ COMMON_DEPEND="
samba? ( net-fs/samba )
sdl? ( media-libs/libsdl2[sound,threads,video] )
v4l? ( media-libs/libv4l )
- vaapi? ( x11-libs/libva[drm?,X?,wayland?] )
+ vaapi? ( x11-libs/libva:=[drm?,X?,wayland?] )
vdpau? ( x11-libs/libvdpau )
wayland? (
>=dev-libs/wayland-1.6.0
>=x11-libs/libxkbcommon-0.3.0
+ dev-libs/wayland-protocols
)
X? (
x11-libs/libX11
@@ -140,7 +141,7 @@ pkg_setup() {
src_prepare() {
cp "${DISTDIR}/waf-${WAF_PV}" "${S}"/waf || die
chmod +x "${S}"/waf || die
- default
+ default_src_prepare
}
src_configure() {
@@ -193,7 +194,6 @@ src_configure() {
--disable-vapoursynth-lazy
$(use_enable archive libarchive)
- --enable-ffmpeg-upstream
--enable-libavdevice
# Audio outputs:
@@ -213,6 +213,8 @@ src_configure() {
$(use_enable aqua cocoa)
$(use_enable drm)
$(use_enable gbm)
+ $(use_enable wayland wayland-scanner)
+ $(use_enable wayland wayland-protocols)
$(use_enable wayland)
$(use_enable X x11)
$(use_enable xv)
@@ -233,8 +235,6 @@ src_configure() {
$(usex libmpv "$(use_enable opengl plain-gl)" '--disable-plain-gl')
--disable-mali-fbdev # Only available in overlays.
$(usex opengl '' '--disable-gl')
- --disable-vulkan # Requires glslang and spirv-tools packaged.
- --disable-shaderc # Only available in overlays.
# HWaccels:
# Automagic Video Toolbox HW acceleration. See Gentoo bug 577332.