summaryrefslogtreecommitdiff
path: root/media-video/mpv/mpv-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /media-video/mpv/mpv-9999.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'media-video/mpv/mpv-9999.ebuild')
-rw-r--r--media-video/mpv/mpv-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 61db0d2cd470..0b5fa6961e19 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -8,7 +8,7 @@ PYTHON_REQ_USE='threads(+)'
WAF_PV=2.0.9
-inherit eapi7-ver flag-o-matic gnome2-utils pax-utils python-r1 toolchain-funcs waf-utils xdg-utils
+inherit bash-completion-r1 eapi7-ver flag-o-matic gnome2-utils pax-utils python-r1 toolchain-funcs waf-utils xdg-utils
DESCRIPTION="Media player based on MPlayer and mplayer2"
HOMEPAGE="https://mpv.io/ https://github.com/mpv-player/mpv"
@@ -59,9 +59,10 @@ REQUIRED_USE="
RESTRICT="!test? ( test )"
COMMON_DEPEND="
+ !!app-shells/mpv-bash-completion
>=media-video/ffmpeg-4.0:0=[encode,threads,vaapi?,vdpau?]
alsa? ( >=media-libs/alsa-lib-1.0.18 )
- archive? ( >=app-arch/libarchive-3.0.0:= )
+ archive? ( >=app-arch/libarchive-3.4.0:= )
bluray? ( >=media-libs/libbluray-0.3.0:= )
cdda? ( dev-libs/libcdio-paranoia )
drm? ( x11-libs/libdrm )
@@ -233,6 +234,7 @@ src_configure() {
# HWaccels:
# Automagic Video Toolbox HW acceleration. See Gentoo bug 577332.
$(use_enable cuda cuda-hwaccel)
+ $(use_enable cuda cuda-interop)
# TV features:
$(use_enable dvb dvbin)
@@ -262,6 +264,11 @@ src_configure() {
--disable-egl-angle-win32
)
+ mywafargs+=(
+ --bashdir="$(get_bashcompdir)"
+ --zshdir="${EPREFIX}"/usr/share/zsh/site-functions
+)
+
# Create reproducible non-live builds.
[[ ${PV} != *9999* ]] && mywafargs+=(--disable-build-date)