summaryrefslogtreecommitdiff
path: root/media-video/mpv/mpv-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-03 07:33:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-03 07:33:54 +0000
commit84d7c5e06639a9bcbf66ae744833b34422e478a6 (patch)
tree48da2d9483d2a87f954b8c4cf7c2024f2c773e45 /media-video/mpv/mpv-9999.ebuild
parent92b7880bd28edc591d46c65b2242bbad6106fb39 (diff)
gentoo auto-resync : 03:03:2023 - 07:33:53
Diffstat (limited to 'media-video/mpv/mpv-9999.ebuild')
-rw-r--r--media-video/mpv/mpv-9999.ebuild25
1 files changed, 1 insertions, 24 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 34293c859ac9..74cbb75b987a 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
LUA_COMPAT=( lua5-1 luajit )
PYTHON_COMPAT=( python3_{9..11} )
-inherit edo flag-o-matic lua-single meson optfeature pax-utils python-single-r1 xdg
+inherit flag-o-matic lua-single meson optfeature pax-utils python-single-r1 xdg
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -243,29 +243,6 @@ src_configure() {
meson_src_configure
}
-src_test() {
- # https://github.com/mpv-player/mpv/blob/master/DOCS/man/options.rst#debugging
- local tests=($("${BUILD_DIR}"/mpv --no-config --unittest=help | tail -n +2; assert))
- (( ${#tests[@]} )) || die "failed to gather any tests"
-
- local skip=(
- all-simple
-
- # fails on non-issue minor inconsistencies (bug #888639)
- img_format
- repack_sws
- )
-
- local test
- for test in "${tests[@]}"; do
- [[ ${test} == @($(IFS='|'; echo "${skip[*]}")) ]] ||
- edo "${BUILD_DIR}"/mpv -v --no-config --unittest="${test}"
- done
-
- # currently only does basic libmpv testing, do in addition to --unittest
- meson_src_test
-}
-
src_install() {
meson_src_install