summaryrefslogtreecommitdiff
path: root/media-video/mpv/mpv-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-video/mpv/mpv-9999.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-video/mpv/mpv-9999.ebuild')
-rw-r--r--media-video/mpv/mpv-9999.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index dd43d1178adb..856b88db74d8 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,20 +29,20 @@ DOCS+=( README.md DOCS/{client-api,interface}-changes.rst )
# See Copyright in sources and Gentoo bug 506946. Waf is BSD, libmpv is ISC.
LICENSE="LGPL-2.1+ GPL-2+ BSD ISC"
SLOT="0"
-IUSE="+alsa aqua archive bluray cdda +cli coreaudio cplugins cuda debug doc drm dvb
+IUSE="+alsa aqua archive bluray cdda +cli coreaudio cplugins debug doc drm dvb
dvd +egl gamepad gbm +iconv jack javascript jpeg lcms libcaca libmpv +lua
- openal +opengl pulseaudio raspberry-pi rubberband sdl
+ nvenc openal +opengl pulseaudio raspberry-pi rubberband sdl
selinux test tools +uchardet vaapi vdpau vulkan wayland +X +xv zlib zimg"
REQUIRED_USE="
|| ( cli libmpv )
aqua? ( opengl )
- cuda? ( opengl )
egl? ( || ( gbm X wayland ) )
gamepad? ( sdl )
gbm? ( drm egl opengl )
lcms? ( opengl )
lua? ( ${LUA_REQUIRED_USE} )
+ nvenc? ( opengl )
opengl? ( || ( aqua egl X raspberry-pi !cli ) )
raspberry-pi? ( opengl )
test? ( opengl )
@@ -93,7 +93,7 @@ COMMON_DEPEND="
vaapi? ( x11-libs/libva:=[drm?,X?,wayland?] )
vdpau? ( x11-libs/libvdpau )
vulkan? (
- >=media-libs/libplacebo-3.104.0:=[vulkan]
+ >=media-libs/libplacebo-4.192.1:=[vulkan]
media-libs/shaderc
)
wayland? (
@@ -118,11 +118,11 @@ COMMON_DEPEND="
"
DEPEND="${COMMON_DEPEND}
${PYTHON_DEPS}
- cuda? ( >=media-libs/nv-codec-headers-8.2.15.7 )
dvb? ( virtual/linuxtv-dvb-headers )
+ nvenc? ( >=media-libs/nv-codec-headers-8.2.15.7 )
"
RDEPEND="${COMMON_DEPEND}
- cuda? ( x11-drivers/nvidia-drivers[X] )
+ nvenc? ( x11-drivers/nvidia-drivers[X] )
selinux? ( sec-policy/selinux-mplayer )
tools? ( ${PYTHON_DEPS} )
"
@@ -224,8 +224,8 @@ src_configure() {
# HWaccels:
# Automagic Video Toolbox HW acceleration. See Gentoo bug 577332.
- $(use_enable cuda cuda-hwaccel)
- $(use_enable cuda cuda-interop)
+ $(use_enable nvenc cuda-hwaccel)
+ $(use_enable nvenc cuda-interop)
# TV features:
$(use_enable dvb dvbin)