summaryrefslogtreecommitdiff
path: root/media-video/mplayer/mplayer-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-15 14:01:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-15 14:01:09 +0000
commitdfa2037f41649c9775d690a3d01cfd5cabf4db71 (patch)
tree261884874fd25b6a9bff06b2e5f6106d091e3848 /media-video/mplayer/mplayer-9999.ebuild
parent8ba94db1fe69019bb2d3b4f50fe9d1ccf3d94b3a (diff)
gentoo auto-resync : 15:02:2023 - 14:01:08
Diffstat (limited to 'media-video/mplayer/mplayer-9999.ebuild')
-rw-r--r--media-video/mplayer/mplayer-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/media-video/mplayer/mplayer-9999.ebuild b/media-video/mplayer/mplayer-9999.ebuild
index c938cefbf668..31de25e10b42 100644
--- a/media-video/mplayer/mplayer-9999.ebuild
+++ b/media-video/mplayer/mplayer-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,12 +11,16 @@ if [[ ${PV} == *9999* ]]; then
RELEASE_URI=""
inherit subversion git-r3
-elif [[ "${PV%_rc*}" == "${PV}" && "${PV%_pre*}" == "${PV}" ]]; then
+elif [[ "${PV%_rc*}" == "${PV}" && "${PV%_pre*}" == "${PV}" && "${PV%_p*}" == "${PV}" ]]; then
MY_P="MPlayer-${PV}"
S="${WORKDIR}/${MY_P}"
RELEASE_URI="mirror://mplayer/releases/${MY_P}.tar.xz"
else
- RELEASE_URI="mirror://gentoo/${P}.tar.xz"
+ # If necessary, don't be afraid to make a snapshot.
+ # http://www.mplayerhq.hu/design7/dload.html says:
+ # "We recommend to always use the latest SVN to get the all the new
+ # features and bugfixes, especially if the release date above looks old."
+ RELEASE_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
fi
FONT_URI="