summaryrefslogtreecommitdiff
path: root/media-video/mpglen/mpglen-0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-video/mpglen/mpglen-0.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-video/mpglen/mpglen-0.1.ebuild')
-rw-r--r--media-video/mpglen/mpglen-0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-video/mpglen/mpglen-0.1.ebuild b/media-video/mpglen/mpglen-0.1.ebuild
new file mode 100644
index 000000000000..9211ffaf64ce
--- /dev/null
+++ b/media-video/mpglen/mpglen-0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="A program to scan through a MPEG file and count the number of GOPs and frames"
+HOMEPAGE="http://www.iamnota.net/mpglen/"
+SRC_URI="http://www.iamnota.net/mpglen/${PN}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ echo 'all: mpglen' > Makefile
+ append-lfs-flags
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install () {
+ dobin ${PN} || die
+ dodoc AUTHORS Changelog README
+}