summaryrefslogtreecommitdiff
path: root/media-video/motiontrack/motiontrack-0.1.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /media-video/motiontrack/motiontrack-0.1.3-r2.ebuild
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'media-video/motiontrack/motiontrack-0.1.3-r2.ebuild')
-rw-r--r--media-video/motiontrack/motiontrack-0.1.3-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-video/motiontrack/motiontrack-0.1.3-r2.ebuild b/media-video/motiontrack/motiontrack-0.1.3-r2.ebuild
new file mode 100644
index 000000000000..36f69311536f
--- /dev/null
+++ b/media-video/motiontrack/motiontrack-0.1.3-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="A set of tools that detect motion between two images"
+SRC_URI="http://gemia.de/motion/${P}.tar.gz"
+HOMEPAGE="http://motiontrack.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="debug graphicsmagick imagemagick multiprocess"
+
+RDEPEND="
+ imagemagick? (
+ !graphicsmagick? ( media-gfx/imagemagick:0= )
+ graphicsmagick? ( media-gfx/graphicsmagick:0=[imagemagick] )
+ )
+ !imagemagick? ( media-libs/gd )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # fix missing inline definition
+ # with GCC 5, bug 570352
+ append-cflags -std=gnu89
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable !imagemagick gd) \
+ $(use_enable imagemagick magick) \
+ $(use_enable multiprocess cluster)
+}
+
+src_install() {
+ default
+ dodoc src/TheCode.txt
+}