summaryrefslogtreecommitdiff
path: root/media-video/motion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /media-video/motion
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'media-video/motion')
-rw-r--r--media-video/motion/Manifest2
-rw-r--r--media-video/motion/motion-4.5.1.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/media-video/motion/Manifest b/media-video/motion/Manifest
index f11583fed08f..2e76468442cd 100644
--- a/media-video/motion/Manifest
+++ b/media-video/motion/Manifest
@@ -2,5 +2,7 @@ AUX motion.confd-r5 884 BLAKE2B 63c497e942ae499271504d308f826f23d718ac968f7735e3
AUX motion.initd-r5 1083 BLAKE2B cc013f9d529b722be26db8ead665380ce1724436f53e0131705bd99177d5f5eabaad939df78995be28d20f002753c7d43b382781660df3f56bf4126bb3cda75c SHA512 4106c502d75f6c5d58766d3bc784dc75b2a1ba0c4897093ed3afb6c1e5efc2032e150d657b8471e70f34ff932c4db93ef1adf55485159bd6906a4766fd5fb12e
AUX motion.service-r4 462 BLAKE2B 3aeac7440cb545bbf7c41a59eb81260202e7783f701ed20ad33e8f69356bcc78ff7a23b3f518df7dc0ab0eb664d05b75e449afa7abbf1f993ad3c77b0eb83fb7 SHA512 2fbcdb381888d63d0becfc04473f915d75f97e267e4fb2bcf2554e53cbc302fd45b544b7c267a99a05540fb79ce4fcf3e3bc7e973fe08d0db5481e7728c02a1f
DIST motion-release-4.3.2.tar.gz 849378 BLAKE2B 2ff49f44bb1d57123760860ae17cc241ecabf3d045ac0c45e1ca08ce3ac8be2fec308492472c37c0d869bc21a7c04658c923c763f9b8f6b547403fc094b03196 SHA512 df54297eebc44b3bc50fd40890c69a9cbbfc5936224bf7027065364e794d7201ceadd99ac99bf43113ec3368f2b5ca435d2956258b9c774e03a6750b41346a7c
+DIST motion-release-4.5.1.tar.gz 856665 BLAKE2B 59ae638113c7f08ced4b18d7c4f19e3b3f1850ba0cd4c224b300be5ac65ae3b45aa391f26f506a91bb4c38a47b552c71db846d2b3217ccf0b2f5799873ab7ddb SHA512 3b8b60ad4f41c37cc215aa575b0295ee99b15f2d32cbf3393c0f7cdd8d87616cca1c00e11cb7bf74e4afa285caa094f08df3ba62ab21dcb28a48336e3ff5803e
EBUILD motion-4.3.2-r1.ebuild 2243 BLAKE2B ea1943f9cc894678905d859c28bb2d0f7b813b8b062dcee4473d6f032f5d3b1387ce3c7087d4b9019e8a2bfbda2d500ae3c3a942ae44ebe44dccea55ede5a0c5 SHA512 29d7a65d5dd47a840cb9972c78efac27fc74989a6020f10ee01a0147f6a9f06b3045d3f99a887d606533b6bb473a6b954f94fbcd1f2cf14cd44ee995aa37ae6d
+EBUILD motion-4.5.1.ebuild 2233 BLAKE2B eb765999b481dbec18f37c9356c5a01100332bb2a473bdd64e61294d2b317eb5732f75f0c4394240d1b3af8f91f0f78b0b33916d8578eb334ea7528d8f417c69 SHA512 da2d28c108e8cdba0a193fef8d495d79e893490fb98eb2c221f5906cf6d8911dc28adddabb637e2eb6378e3ca046e2591aeb97504a3d2008e0e1b5a9064605ab
MISC metadata.xml 766 BLAKE2B 1385dc89a2d67fc06b0c430b7cb6a606ce22af15c633edc78382e48bc14e423a2a4ff1553531e0e373151e48d2fed1ab78f9da67680fda3eea6b3d717b077d22 SHA512 8c944d3b1bb54b25597bae085b3fdc3da3ff3677eb97fee314558597917355a2fa4db4216720dc51aa171bb032eb426ae8b1d3c9bc5efed3662af75d8d49cc54
diff --git a/media-video/motion/motion-4.5.1.ebuild b/media-video/motion/motion-4.5.1.ebuild
new file mode 100644
index 000000000000..ee5f5d8492c9
--- /dev/null
+++ b/media-video/motion/motion-4.5.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools readme.gentoo-r1 systemd
+
+DESCRIPTION="A software motion detector"
+HOMEPAGE="https://motion-project.github.io"
+SRC_URI="https://github.com/Motion-Project/${PN}/archive/release-${PV}.tar.gz -> ${PN}-release-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ffmpeg mariadb mmal mysql postgres sqlite v4l webp"
+
+RDEPEND="
+ acct-group/motion
+ acct-user/motion
+ net-libs/libmicrohttpd:=
+ media-libs/libjpeg-turbo:=
+ >=sys-devel/gettext-0.19
+ ffmpeg? ( media-video/ffmpeg:0= )
+ mariadb? ( dev-db/mariadb-connector-c )
+ mmal? ( media-libs/raspberrypi-userland )
+ mysql? ( dev-db/mysql-connector-c )
+ postgres? ( dev-db/postgresql:= )
+ sqlite? ( dev-db/sqlite:3 )
+ webp? ( media-libs/libwebp:= )
+"
+DEPEND="${RDEPEND}
+ v4l? (
+ media-libs/libv4l
+ virtual/os-headers
+ )
+"
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+You need to setup a configuraton file (/etc/motion/motion.conf) before
+running motion for the first time.
+
+If motion is built with the mysql or mariadb use flags then please make
+sure to configure a matching database_type in the config file.
+
+Motion runs by default under user motion and group motion:
+- change this if needed in /etc/conf.d/motion
+- or add users who need access to the output files to the motion group
+
+To install motion as a service, use:
+- rc-update add motion default # with OpenRC
+- systemctl enable motion.service # with systemd
+"
+
+S="${WORKDIR}"/${PN}-release-${PV}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with ffmpeg) \
+ $(use_with mariadb) \
+ $(use_with mmal) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with sqlite sqlite3) \
+ $(use_with v4l v4l2) \
+ $(use_with webp) \
+ --without-optimizecpu
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF} \
+ examplesdir=/usr/share/doc/${PF}/examples \
+ install
+
+ newinitd "${FILESDIR}/motion.initd-r5" ${PN}
+ newconfd "${FILESDIR}/motion.confd-r5" ${PN}
+ systemd_newunit "${FILESDIR}/${PN}.service-r4" "${PN}.service"
+ readme.gentoo_create_doc
+ readme.gentoo_print_elog
+}