summaryrefslogtreecommitdiff
path: root/media-video/motion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-10 23:34:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-10 23:34:33 +0000
commit0771aa27d30f102abe2c5733a138ffe570da4d15 (patch)
tree1ce3f24ab882caa90bf65381e4f0794872fc7d93 /media-video/motion
parent0bb42730e8fc9c8e571f12e3189c6c6f8d532c24 (diff)
gentoo auto-resync : 10:02:2024 - 23:34:33
Diffstat (limited to 'media-video/motion')
-rw-r--r--media-video/motion/Manifest1
-rw-r--r--media-video/motion/motion-4.5.1-r4.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/media-video/motion/Manifest b/media-video/motion/Manifest
index 15c98a30e399..e858f6e4f7d0 100644
--- a/media-video/motion/Manifest
+++ b/media-video/motion/Manifest
@@ -5,4 +5,5 @@ AUX motion.initd-r5 1392 BLAKE2B 87ac71a1e75ace73ac28c52ff0b1d6bbce364e6d43ef860
AUX motion.service-r4 497 BLAKE2B 8941424317635d214e74d5d558a443212129c38fed9921b101bd3689d743ed6bd68e30748075ae8c5d26aa10732fc6ce1f08707c9ed559eb89a27322e57e0995 SHA512 44e0fa13e4d93af517a06bac5191d16d528648c6b3eb9d56f80e447db7ef46b311acf6fd1d2159a24fa22200be41bdc62eeef8670ddba918bdd28f6d710f90c0
DIST motion-release-4.5.1.tar.gz 856665 BLAKE2B 59ae638113c7f08ced4b18d7c4f19e3b3f1850ba0cd4c224b300be5ac65ae3b45aa391f26f506a91bb4c38a47b552c71db846d2b3217ccf0b2f5799873ab7ddb SHA512 3b8b60ad4f41c37cc215aa575b0295ee99b15f2d32cbf3393c0f7cdd8d87616cca1c00e11cb7bf74e4afa285caa094f08df3ba62ab21dcb28a48336e3ff5803e
EBUILD motion-4.5.1-r3.ebuild 2348 BLAKE2B d55e46855de12b6c63cf90540d129aa93f387cf91ff890f00a06215b583b748f0b1528d3b9a6f323424ef343fcec515566b61f26081b2684eab6b80a8feebc30 SHA512 665dcb6486be8eaf3e82c9afd93c47f6fc29361a273159873908fabfe1934d6c017a220251be20ac3a8de4a6ac591c240684646a1ef3bf6d2b72d04364e0d546
+EBUILD motion-4.5.1-r4.ebuild 2281 BLAKE2B 45c63007c6a8e91866412f4bf8b67b7d224c7015ff903dbd0750324d2dbc06744faad2de30468ee1221bdb8ee5d5843b4544a6fdb8a339369c91755d1949c40c SHA512 efef2a9774338ab4951107f08abc523a3d1b7957ccdf68e672f0658c7f3d7179f469fb51c67891f4c847b726d06f94fb57656d66e5e96814240a5746a31b05f4
MISC metadata.xml 766 BLAKE2B 1385dc89a2d67fc06b0c430b7cb6a606ce22af15c633edc78382e48bc14e423a2a4ff1553531e0e373151e48d2fed1ab78f9da67680fda3eea6b3d717b077d22 SHA512 8c944d3b1bb54b25597bae085b3fdc3da3ff3677eb97fee314558597917355a2fa4db4216720dc51aa171bb032eb426ae8b1d3c9bc5efed3662af75d8d49cc54
diff --git a/media-video/motion/motion-4.5.1-r4.ebuild b/media-video/motion/motion-4.5.1-r4.ebuild
new file mode 100644
index 000000000000..691023faf1fd
--- /dev/null
+++ b/media-video/motion/motion-4.5.1-r4.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools readme.gentoo-r1 systemd
+
+DESCRIPTION="A software motion detector"
+HOMEPAGE="https://motion-project.github.io"
+SRC_URI="https://github.com/Motion-Project/${PN}/archive/release-${PV}.tar.gz -> ${PN}-release-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-release-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ffmpeg mariadb mysql postgres sqlite v4l webp"
+
+RDEPEND="
+ acct-group/motion
+ acct-user/motion
+ net-libs/libmicrohttpd:=
+ media-libs/libjpeg-turbo:=
+ >=sys-devel/gettext-0.19
+ ffmpeg? ( media-video/ffmpeg:0= )
+ mariadb? ( dev-db/mariadb-connector-c )
+ mysql? ( dev-db/mysql-connector-c )
+ postgres? ( dev-db/postgresql:= )
+ sqlite? ( dev-db/sqlite:3 )
+ webp? ( media-libs/libwebp:= )
+"
+DEPEND="${RDEPEND}
+ v4l? (
+ media-libs/libv4l
+ virtual/os-headers
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-gettext-0.22-format-specifier.patch
+ "${FILESDIR}"/${P}-webp-underlinking.patch
+)
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+You need to setup a configuraton file (/etc/motion/motion.conf) before
+running motion for the first time.
+
+If motion is built with the mysql or mariadb use flags then please make
+sure to configure a matching database_type in the config file.
+
+Motion runs by default under user motion and group motion:
+- change this if needed in /etc/conf.d/motion
+- or add users who need access to the output files to the motion group
+
+To install motion as a service, use:
+- rc-update add motion default # with OpenRC
+- systemctl enable motion.service # with systemd
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with ffmpeg) \
+ $(use_with mariadb) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with sqlite sqlite3) \
+ $(use_with v4l v4l2) \
+ $(use_with webp) \
+ --without-optimizecpu
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF} \
+ examplesdir=/usr/share/doc/${PF}/examples \
+ install
+
+ newinitd "${FILESDIR}/motion.initd-r5" ${PN}
+ newconfd "${FILESDIR}/motion.confd-r5" ${PN}
+ systemd_newunit "${FILESDIR}/${PN}.service-r4" "${PN}.service"
+ readme.gentoo_create_doc
+ readme.gentoo_print_elog
+}