summaryrefslogtreecommitdiff
path: root/media-video/mkclean/mkclean-0.8.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /media-video/mkclean/mkclean-0.8.10.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'media-video/mkclean/mkclean-0.8.10.ebuild')
-rw-r--r--media-video/mkclean/mkclean-0.8.10.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/media-video/mkclean/mkclean-0.8.10.ebuild b/media-video/mkclean/mkclean-0.8.10.ebuild
index c094af08ab56..35ddf2b4dfca 100644
--- a/media-video/mkclean/mkclean-0.8.10.ebuild
+++ b/media-video/mkclean/mkclean-0.8.10.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
inherit toolchain-funcs
@@ -12,7 +12,6 @@ SRC_URI="http://downloads.sourceforge.net/project/matroska/${PN}/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
src_configure() {
tc-export CC CXX
@@ -23,8 +22,13 @@ src_configure() {
./coremake $(corec/tools/coremake/system_output.sh) || die
# fixing generated makefiles
- sed -i -e 's|^\(LFLAGS.*+=.*\$(LIBS)\)|\1 \$(LDFLAGS)|g' \
- -e 's|^\(STRIP.*=\)|\1 echo|g' $(find -name "*.mak") || die
+ local f
+ while IFS="" read -d $'\0' -r f; do
+ sed \
+ -e 's|^\(LFLAGS.*+=.*\$(LIBS)\)|\1 \$(LDFLAGS)|g' \
+ -e 's|^\(STRIP.*=\)|\1 echo|g' \
+ -i "${f}" || die
+ done < <(find -name "*.mak" -type f -print0)
}
src_compile() {