summaryrefslogtreecommitdiff
path: root/media-video/matroxset/matroxset-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-video/matroxset/matroxset-0.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-video/matroxset/matroxset-0.4.ebuild')
-rw-r--r--media-video/matroxset/matroxset-0.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-video/matroxset/matroxset-0.4.ebuild b/media-video/matroxset/matroxset-0.4.ebuild
new file mode 100644
index 000000000000..cd27fbb824d1
--- /dev/null
+++ b/media-video/matroxset/matroxset-0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit toolchain-funcs
+
+IUSE=""
+
+DESCRIPTION="Matrox utility to switch output modes (activate tvout)"
+HOMEPAGE="ftp://platan.vc.cvut.cz/pub/linux/matrox-latest/"
+SRC_URI="ftp://platan.vc.cvut.cz/pub/linux/matrox-latest/${P}.tar.gz"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+
+doecho() {
+ echo "$@"
+ "$@"
+}
+
+src_compile() {
+ doecho $(tc-getCC) -o ${PN} \
+ ${CFLAGS} ${LDFLAGS} \
+ ${PN}.c -lncurses \
+ || die "build failed"
+
+ #prepare small README
+ cat >> "${S}"/README << _EOF_
+This utility has been created by Petr Vandrovec
+
+Not much info here, but here are some pointers
+http://davedina.apestaart.org/download/doc/Matrox-TVOUT-HOWTO-0.1.txt
+http://www.netnode.de/howto/matrox-fb.html
+_EOF_
+}
+
+src_install() {
+ dobin matroxset || die
+
+ dodoc README || die
+}