summaryrefslogtreecommitdiff
path: root/media-video/kamerka/kamerka-0.12_p20161002-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-20 18:45:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-20 18:45:28 +0000
commit796cae72cf9ed18ba01256ac1f83a686a2a76036 (patch)
tree5ca737a2562d8c0a09fcfacd81d1f9004df37b00 /media-video/kamerka/kamerka-0.12_p20161002-r1.ebuild
parent20d8e9cfb95a9f054d654ab6405e848807186aa0 (diff)
gentoo resync : 20.11.2017
Diffstat (limited to 'media-video/kamerka/kamerka-0.12_p20161002-r1.ebuild')
-rw-r--r--media-video/kamerka/kamerka-0.12_p20161002-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-video/kamerka/kamerka-0.12_p20161002-r1.ebuild b/media-video/kamerka/kamerka-0.12_p20161002-r1.ebuild
new file mode 100644
index 000000000000..c31df0915797
--- /dev/null
+++ b/media-video/kamerka/kamerka-0.12_p20161002-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT="a201df47a0849a09a20617fedfee26a407dc847c"
+inherit kde5 vcs-snapshot
+
+DESCRIPTION="Simple photo taking application with fancy animated interface"
+HOMEPAGE="https://dos1.github.io/kamerka/ https://github.com/dos1/kamerka"
+SRC_URI="https://github.com/dos1/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtscript)
+ $(add_qt_dep qtwidgets)
+ media-libs/libv4l
+ media-libs/phonon[qt5(+)]
+ >=media-libs/qimageblitz-0.0.6_p20131029[qt5(+)]
+"
+RDEPEND="${DEPEND}"