summaryrefslogtreecommitdiff
path: root/media-video/harvid/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-26 08:58:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-26 08:58:19 +0100
commit34ce8f465101950c92cb66c657d3244b5a8397db (patch)
tree5df8a8c3a293be4942f5df9f9cd81babb70fac96 /media-video/harvid/files
parent24162508832f37f873ab12dfdfb191cf99318055 (diff)
gentoo auto-resync : 26:07:2022 - 08:58:19
Diffstat (limited to 'media-video/harvid/files')
-rw-r--r--media-video/harvid/files/harvid-0.9.0-ffmpeg.patch21
-rw-r--r--media-video/harvid/files/harvid-0.9.0-parallel-build.patch40
2 files changed, 61 insertions, 0 deletions
diff --git a/media-video/harvid/files/harvid-0.9.0-ffmpeg.patch b/media-video/harvid/files/harvid-0.9.0-ffmpeg.patch
new file mode 100644
index 000000000000..6422f7503cff
--- /dev/null
+++ b/media-video/harvid/files/harvid-0.9.0-ffmpeg.patch
@@ -0,0 +1,21 @@
+https://github.com/x42/harvid/commit/5da512c504e6d1cef9546a33f16d2b466289b1f6
+
+From: Robin Gareus <robin@gareus.org>
+Date: Sat, 23 Apr 2022 02:30:59 +0200
+Subject: [PATCH] Fix ffmpeg compatibility
+
+--- a/libharvid/ffcompat.h
++++ b/libharvid/ffcompat.h
+@@ -75,8 +75,10 @@ static inline void av_packet_unref (AVPacket *pkt)
+ #if LIBAVUTIL_VERSION_INT < AV_VERSION_INT(51, 63, 100)
+ static inline int av_image_get_buffer_size (enum AVPixelFormat pix_fmt, int width, int height, int align)
+ {
+- return avpicture_get_size (pix_fmt, width, height)
++ return avpicture_get_size (pix_fmt, width, height);
+ }
++#else
++#include <libavutil/imgutils.h>
+ #endif
+
+ #if LIBAVFORMAT_VERSION_INT < AV_VERSION_INT(53, 2, 0)
+
diff --git a/media-video/harvid/files/harvid-0.9.0-parallel-build.patch b/media-video/harvid/files/harvid-0.9.0-parallel-build.patch
new file mode 100644
index 000000000000..c45ce7a70a84
--- /dev/null
+++ b/media-video/harvid/files/harvid-0.9.0-parallel-build.patch
@@ -0,0 +1,40 @@
+https://github.com/x42/harvid/commit/a3f85c57ad2559558706d9b22989de36452704d9
+
+From: Sergei Trofimovich <slyich@gmail.com>
+Date: Wed, 22 Jun 2022 23:18:16 +0100
+Subject: [PATCH] Makefile: add a missing target libharvid dependency of src
+
+Without the change parallel build fails sometimes by linking
+too early on non-existent file:
+
+ make -C src
+ make[1]: Entering directory '/build/harvid/src'
+ ld -r -b binary -o seek.o ../doc/seek.js
+ ld -r -b binary -o logo.o ../doc/harvid.jpg
+ make[1]: *** No rule to make target '../libharvid/libharvid.a', needed by 'harvid'. Stop.
+
+It's nest reproducible in `make --shuffle` mode:
+ https://savannah.gnu.org/bugs/index.php?62100
+
+The change makes sure 'libharvid' is built before 'src'.
+--- a/Makefile
++++ b/Makefile
+@@ -3,12 +3,15 @@ SUBDIRS = libharvid src doc
+
+ default: all
+
+-$(SUBDIRS)::
++$(SUBDIRS):
+ $(MAKE) -C $@ $(MAKECMDGOALS)
+
+ all clean man install uninstall install-bin install-man uninstall-bin uninstall-man install-lib uninstall-lib: $(SUBDIRS)
+
++# final binary links against a library
++src: libharvid
++
+ dist:
+ git archive --format=tar --prefix=harvid-$(VERSION)/ HEAD | gzip -9 > harvid-$(VERSION).tar.gz
+
+-.PHONY: clean all subdirs install uninstall dist install-bin install-man uninstall-bin uninstall-man install-lib uninstall-lib
++.PHONY: clean all subdirs install uninstall dist install-bin install-man uninstall-bin uninstall-man install-lib uninstall-lib $(SUBDIRS)
+