summaryrefslogtreecommitdiff
path: root/media-video/gaupol
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
commit6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (patch)
treecee0a97398040001220ece3cd48c3d568bcddb4a /media-video/gaupol
parent1db00cc6e94b90c08090bb5b8c406622946c4ae5 (diff)
gentoo resync : 10.02.2019
Diffstat (limited to 'media-video/gaupol')
-rw-r--r--media-video/gaupol/Manifest2
-rw-r--r--media-video/gaupol/gaupol-1.5.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/media-video/gaupol/Manifest b/media-video/gaupol/Manifest
index 8493554490eb..9c1f1fc3ccd1 100644
--- a/media-video/gaupol/Manifest
+++ b/media-video/gaupol/Manifest
@@ -1,5 +1,7 @@
DIST gaupol-1.4.1.tar.gz 524816 BLAKE2B 677f1ee0e3b523f97d4b0f6491547d07a658c41c3c2c0f76732589592b542176761df28e13735af58371594043ef234f7987988deacd4d8f73554a87f555d001 SHA512 464e71390ba13f1da11bd40ecb4683d146acb6e547204231a2e78c24719b4ad9ba188210d1bf2108924bcfa0df89c0296f428cba693d3b6d4366e98950cb072a
DIST gaupol-1.4.tar.gz 524369 BLAKE2B 6f27ce3328339fc2f6248bb58d80965a5a26fed220ddf9c989a5029b4322ea790f768cb9e0472bb2c5eae4e4da3abd4b0f808e785273ff9fb787ff5b7df5d137 SHA512 da9256dd8dafeaff012226a8ff09807c7cb7609c293bde7d90b05b4f75c47751e65181f1bf47dff1c8e979f48186996253141ff18e849786bf2cff5ed5555148
+DIST gaupol-1.5.tar.gz 537279 BLAKE2B 1ba8644b49832ee80e61bf304b7978275064acbe2e5e733a991b280f947c4064f0d4f385055e580bd3aa2d9ee2291d64fd1ee4bd8a1ba4f8eaaaaf9a137085ff SHA512 48f3eda460c2fb3e4bdaf52c42645599f0d5ce8eae05f7a2a9c608192a27a8b86b83830584216dc73105968f544aeab30e171b2c176d9a3f5047e93510413b85
EBUILD gaupol-1.4.1.ebuild 1386 BLAKE2B 5ec40c5e0af3db14aa3453d7fe586ea0b346ecde6cc73f8d5f812279b23db7ca72915b386c78c719ca057f2f6a4a445c2673be4711d6d3ccfad6b26fc563b14b SHA512 b34e09c2ca5f21cdf6227d9ec0cc9836d004367686753d33ad4c0d7415a9456cf5325b0c3710e9da142640ca3c0a040037d69772bf878f0577ee7441fcfc2b3f
EBUILD gaupol-1.4.ebuild 1424 BLAKE2B 95b4045fa111616491df258bee5542338e04209b7083fae27901b50255eaefe75be5c94cbe7d976e2b57365ed5f6d6a9287da586bd9971155a0d4cb88d73761f SHA512 1a74311606a5dfe5c8b827fa8ac01d258fbbdc2d9b635433c90a088ceb10994cfc3bdc229073fa5e47200ba3bb1726a4c6bcb385ac0366f93d4ab23452b54dcc
+EBUILD gaupol-1.5.ebuild 1386 BLAKE2B c2975885e300ccf4cb1a572eeceacd596e949c7cf176a322a67c66afcc1237cb9fc1f23b0996035f5fe80dca219f1a56384b0abc5ce41f1e714a7ff00d6f3ef1 SHA512 5a65e0e7902637341f190982cba98131fe9c8a6ba9e1d90bc951c7d5fc757f935bc1d410685fac43c7c7603e32a7263e1d542c2d9547e07b96b6d6ca7973cb27
MISC metadata.xml 508 BLAKE2B 979a43569103cfe36a47d56ed16c15b7775d0a36d031d488ac064152b8d59115dc656e28a5eced25da13d9a3925be24114a760862bf043b88a89c70b8dc053e8 SHA512 1af2a5a287075a0668850c229a5c9dcbef51bbe64467516e37b870459266021d528435dbd5274e0d5abf7cf0fe2d4b8fb08f6cc470418c3b64e4da6b93dcc147
diff --git a/media-video/gaupol/gaupol-1.5.ebuild b/media-video/gaupol/gaupol-1.5.ebuild
new file mode 100644
index 000000000000..0f7e6db10bdc
--- /dev/null
+++ b/media-video/gaupol/gaupol-1.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+
+inherit distutils-r1 gnome2-utils virtualx xdg-utils
+
+DESCRIPTION="A subtitle editor for text-based subtitles"
+HOMEPAGE="https://otsaloma.io/gaupol/"
+SRC_URI="https://github.com/otsaloma/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="spell test"
+
+RDEPEND="
+ app-text/iso-codes
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ spell? (
+ app-text/gtkspell:3
+ >=dev-python/pyenchant-1.4[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ sys-devel/gettext
+ test? (
+ ${RDEPEND}
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( AUTHORS.md NEWS.md TODO.md README.md README.aeidon.md )
+
+python_test() {
+ virtx pytest -vv
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Previewing support needs MPV, MPlayer or VLC."
+
+ if use spell; then
+ elog "Additionally, spell-checking requires a dictionary, any of"
+ elog "Aspell/Pspell, Ispell, MySpell, Uspell, Hspell or AppleSpell."
+ fi
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}