summaryrefslogtreecommitdiff
path: root/media-video/frameworks/frameworks-0.3.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-video/frameworks/frameworks-0.3.7-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-video/frameworks/frameworks-0.3.7-r1.ebuild')
-rw-r--r--media-video/frameworks/frameworks-0.3.7-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-video/frameworks/frameworks-0.3.7-r1.ebuild b/media-video/frameworks/frameworks-0.3.7-r1.ebuild
new file mode 100644
index 000000000000..cbaab961263b
--- /dev/null
+++ b/media-video/frameworks/frameworks-0.3.7-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="A small v4l frame capture utility especially suited for stop motion animation"
+SRC_URI="http://frameworks.polycrystal.org/release/${P}.tar.gz"
+HOMEPAGE="http://frameworks.polycrystal.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~x86 ~amd64"
+
+RDEPEND="
+ >=gnome-base/libglade-2
+ x11-libs/gtk+:2
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=(
+ AUTHORS ChangeLog NEWS README TODO
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.7-ceilf.patch
+ "${FILESDIR}"/${PN}-0.3.7-strcmp-and-datadir.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}