summaryrefslogtreecommitdiff
path: root/media-video/ffmpeg/ffmpeg-5.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-03 13:53:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-03 13:53:01 +0100
commit4b4d352fc9761396c68812d8eccc63b7b14d6558 (patch)
tree4f290d635d831599222130ba8ddbf1a726129426 /media-video/ffmpeg/ffmpeg-5.0.1.ebuild
parenta2c1a301b2ea85c230b30ef69ff667f230a1bf88 (diff)
gentoo auto-resync : 03.08.2022 - 13:42:43
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-5.0.1.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-5.0.1.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/media-video/ffmpeg/ffmpeg-5.0.1.ebuild b/media-video/ffmpeg/ffmpeg-5.0.1.ebuild
index d3e7c93b04de..17f3f4c919f0 100644
--- a/media-video/ffmpeg/ffmpeg-5.0.1.ebuild
+++ b/media-video/ffmpeg/ffmpeg-5.0.1.ebuild
@@ -343,6 +343,20 @@ build_separate_libffmpeg() {
use opencl
}
+pkg_setup() {
+ # ffmpeg[chromaprint] depends on chromaprint, and chromaprint[tools] depends on ffmpeg.
+ # May cause breakage while updating, #862996, #625210, #833821.
+ if has_version media-libs/chromaprint[tools] && use chromaprint; then
+ ewarn "You have media-libs/chromaprint installed with 'tools' USE flag, which "
+ ewarn "links to ffmpeg, and you have enabled 'chromaprint' USE flag for ffmpeg, "
+ ewarn "which links to chromaprint. This may cause issues while rebuilding ffmpeg."
+ ewarn ""
+ ewarn "If your build fails to 'ERROR: chromaprint not found', rebuild chromaprint "
+ ewarn "without the 'tools' use flag first, then rebuild ffmpeg, and then finally enable "
+ ewarn "'tools' USE flag for chromaprint. See #862996."
+ fi
+}
+
src_prepare() {
if [[ "${PV%_p*}" != "${PV}" ]] ; then # Snapshot
export revision=git-N-${FFMPEG_REVISION}