summaryrefslogtreecommitdiff
path: root/media-video/dvdbackup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /media-video/dvdbackup
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'media-video/dvdbackup')
-rw-r--r--media-video/dvdbackup/Manifest3
-rw-r--r--media-video/dvdbackup/dvdbackup-0.4.2.ebuild1
-rw-r--r--media-video/dvdbackup/files/libdvdread-6.1.0.diff92
3 files changed, 95 insertions, 1 deletions
diff --git a/media-video/dvdbackup/Manifest b/media-video/dvdbackup/Manifest
index 8cace0ade9cc..535ba8db2186 100644
--- a/media-video/dvdbackup/Manifest
+++ b/media-video/dvdbackup/Manifest
@@ -1,3 +1,4 @@
+AUX libdvdread-6.1.0.diff 2974 BLAKE2B f064abf3d1cf903706af026465cdbef3a27ce1f6a6cf1ab15c7af411bda7358b672b83072fc5ed2d0572ff6c4d736a0d7b56690f4ebcc7b7e8f3b294417b3e9f SHA512 cd16d6cd2e95d2120682659b31e1f0d6f98e7a394fe0ab08139c8519ec9b1e97845fb88c09f5117af361d22c4e22258d85392b13e3f9347073626d3868c5310c
DIST dvdbackup-0.4.2.tar.xz 178660 BLAKE2B 1403bd66861713803a2da00712318a6cb399d5c7640cadd27f55fb1cee4e0013364f17a2dc3c78dab819d4fdb8405d36e781d0f2abd1bfb49873b0992d5f2dcc SHA512 df9abb2ca0b8a7cd7855ddff94dae249b06b2ec0ee42f3e9c53aa46aebd9885bdf26dacecbd4a20ff5f642ea10c0c64b811d25c23802c8a2b1489281900fbe0d
-EBUILD dvdbackup-0.4.2.ebuild 570 BLAKE2B 578fbf3b747e1341124cf1f558aad49de22f403432065e90950896ca0366471144bae13f74509b48d979ed36e20074e4d2381ba3a69f49077a84b66833dd2f17 SHA512 46e662a88bb53956d2b625708ae89e019294d7a4bd509e1dff8e9d79ace317533207f197c320ad019e6529df48b69db59e69f0dd76472288a18742323b4feda7
+EBUILD dvdbackup-0.4.2.ebuild 618 BLAKE2B 34c195daaecc531f865cd8a410deaeb890fda8169ec4e969fd09380a41b6914773dc626d4c1061d65c599a9bb771089fff0dc282db84f255f2b8b7b7dc647596 SHA512 abf42585d005aadf37692827b02f513f93960715a30ebe2f28c29676cf2a3ac1593119657c5819443b5d4f9704dadec9dd3b7848d79899c76c797ed2cd910add
MISC metadata.xml 302 BLAKE2B 7d62d6d1c62ddc1245f787ac6faf77c317ce298033e48c17433c09ea2ff92acd05af2ffa44071df281a8da4bacaf6b3c35633475f0496af3a1515e038b1ec79c SHA512 85850b8f0f8de515d846da33fced47ff85195616dc93562edbc62f11bb1108a101cdcd0db7c54be28c17f56f8cea15af9839cfe34fe2b207ba002f770e9e205f
diff --git a/media-video/dvdbackup/dvdbackup-0.4.2.ebuild b/media-video/dvdbackup/dvdbackup-0.4.2.ebuild
index f4dfc5d11ca9..de49049c825e 100644
--- a/media-video/dvdbackup/dvdbackup-0.4.2.ebuild
+++ b/media-video/dvdbackup/dvdbackup-0.4.2.ebuild
@@ -16,6 +16,7 @@ RDEPEND=">=media-libs/libdvdread-4.2.0_pre
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
+PATCHES=( "${FILESDIR}/libdvdread-6.1.0.diff" )
src_configure() {
econf \
diff --git a/media-video/dvdbackup/files/libdvdread-6.1.0.diff b/media-video/dvdbackup/files/libdvdread-6.1.0.diff
new file mode 100644
index 000000000000..06986c36c760
--- /dev/null
+++ b/media-video/dvdbackup/files/libdvdread-6.1.0.diff
@@ -0,0 +1,92 @@
+https://bugs.gentoo.org/721732
+
+https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=245228
+https://bugs.launchpad.net/dvdbackup/+bug/1869226
+
+--- a/src/dvdbackup.c
++++ b/src/dvdbackup.c
+@@ -1132,7 +1132,7 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+ int size;
+
+ /* DVD handler */
+- ifo_handle_t* ifo_file = NULL;
++ dvd_file_t* ifo_file = NULL;
+
+
+ if (title_set_info->number_of_title_sets + 1 < title_set) {
+@@ -1181,7 +1181,7 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+ if ((streamout_ifo = open(targetname_ifo, O_WRONLY | O_CREAT | O_TRUNC, 0666)) == -1) {
+ fprintf(stderr, _("Error creating %s\n"), targetname_ifo);
+ perror(PACKAGE);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+@@ -1191,7 +1191,7 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+ if ((streamout_bup = open(targetname_bup, O_WRONLY | O_CREAT | O_TRUNC, 0666)) == -1) {
+ fprintf(stderr, _("Error creating %s\n"), targetname_bup);
+ perror(PACKAGE);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+@@ -1200,31 +1200,31 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+
+ /* Copy VIDEO_TS.IFO, since it's a small file try to copy it in one shot */
+
+- if ((ifo_file = ifoOpen(dvd, title_set))== 0) {
++ if ((ifo_file = DVDOpenFile(dvd, title_set, DVD_READ_INFO_FILE))== 0) {
+ fprintf(stderr, _("Failed opening IFO for title set %d\n"), title_set);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+ return 1;
+ }
+
+- size = DVDFileSize(ifo_file->file) * DVD_VIDEO_LB_LEN;
++ size = DVDFileSize(ifo_file) * DVD_VIDEO_LB_LEN;
+
+ if ((buffer = (unsigned char *)malloc(size * sizeof(unsigned char))) == NULL) {
+ perror(PACKAGE);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+ return 1;
+ }
+
+- DVDFileSeek(ifo_file->file, 0);
++ DVDFileSeek(ifo_file, 0);
+
+- if (DVDReadBytes(ifo_file->file,buffer,size) != size) {
++ if (DVDReadBytes(ifo_file,buffer,size) != size) {
+ fprintf(stderr, _("Error reading IFO for title set %d\n"), title_set);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+@@ -1234,7 +1234,7 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+
+ if (write(streamout_ifo,buffer,size) != size) {
+ fprintf(stderr, _("Error writing %s\n"),targetname_ifo);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+@@ -1243,7 +1243,7 @@ static int DVDCopyIfoBup(dvd_reader_t* dvd, title_set_
+
+ if (write(streamout_bup,buffer,size) != size) {
+ fprintf(stderr, _("Error writing %s\n"),targetname_bup);
+- ifoClose(ifo_file);
++ DVDCloseFile(ifo_file);
+ free(buffer);
+ close(streamout_ifo);
+ close(streamout_bup);
+