summaryrefslogtreecommitdiff
path: root/media-video/ccextractor/ccextractor-0.59.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-video/ccextractor/ccextractor-0.59.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-video/ccextractor/ccextractor-0.59.ebuild')
-rw-r--r--media-video/ccextractor/ccextractor-0.59.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-video/ccextractor/ccextractor-0.59.ebuild b/media-video/ccextractor/ccextractor-0.59.ebuild
new file mode 100644
index 000000000000..83c1fae4d223
--- /dev/null
+++ b/media-video/ccextractor/ccextractor-0.59.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Extract closed captioning subtitles from video to SRT"
+HOMEPAGE="http://ccextractor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ccextractor/${P}-src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ cd src
+ $(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} -D_FILE_OFFSET_BITS=64 -o ccextractor *.cpp || die
+}
+
+src_install() {
+ dobin src/ccextractor
+ dodoc docs/*.TXT
+}