summaryrefslogtreecommitdiff
path: root/media-video/camorama/camorama-0.19-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-video/camorama/camorama-0.19-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-video/camorama/camorama-0.19-r2.ebuild')
-rw-r--r--media-video/camorama/camorama-0.19-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-video/camorama/camorama-0.19-r2.ebuild b/media-video/camorama/camorama-0.19-r2.ebuild
new file mode 100644
index 000000000000..a89953f93224
--- /dev/null
+++ b/media-video/camorama/camorama-0.19-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit eutils gnome2
+
+DESCRIPTION="A webcam application featuring various image filters"
+HOMEPAGE="https://git.gnome.org/browse/camorama/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnome-2
+ gnome-base/libgnome-keyring
+ >=gnome-base/libgnomeui-2
+ media-libs/libv4l
+ x11-libs/gtk+:2
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gconf.patch \
+ "${FILESDIR}"/${P}-fixes.patch \
+ "${FILESDIR}"/${P}-libv4l.patch \
+ "${FILESDIR}"/${P}-no-more-videodev_h.patch \
+ "${FILESDIR}"/${P}-glib-232.patch
+
+ gnome2_src_prepare
+}