summaryrefslogtreecommitdiff
path: root/media-video/blinkensim/blinkensim-2.7-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-04 13:17:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-04 13:17:38 +0100
commit78754950ffa3aaba0f48b1ca1d505caa4a3dfbfa (patch)
tree285997f09f32d26633ba2beffd30c972a4ec87a2 /media-video/blinkensim/blinkensim-2.7-r2.ebuild
parentbf99f8024d68382f76665735c70ae912331bc2ca (diff)
gentoo auto-resync : 04:10:2022 - 13:17:38
Diffstat (limited to 'media-video/blinkensim/blinkensim-2.7-r2.ebuild')
-rw-r--r--media-video/blinkensim/blinkensim-2.7-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-video/blinkensim/blinkensim-2.7-r2.ebuild b/media-video/blinkensim/blinkensim-2.7-r2.ebuild
new file mode 100644
index 000000000000..6ed9e5cc9d26
--- /dev/null
+++ b/media-video/blinkensim/blinkensim-2.7-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Graphical Blinkenlights simulator with networking support"
+HOMEPAGE="http://blinkenlights.net/project/developer-tools"
+SRC_URI="http://blinkenlights.de/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="aalib gtk"
+
+# if the config script finds any of the optional library it will try to
+# compile against it
+RDEPEND="
+ >=media-libs/blib-1.1.4
+ media-video/blinkenthemes
+ aalib? ( >=media-libs/aalib-1.4_rc4-r2 )
+ gtk? ( >=x11-libs/gtk+-2.4.4:2 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}