summaryrefslogtreecommitdiff
path: root/media-video/bbtools/bbtools-1.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-video/bbtools/bbtools-1.9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-video/bbtools/bbtools-1.9.ebuild')
-rw-r--r--media-video/bbtools/bbtools-1.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-video/bbtools/bbtools-1.9.ebuild b/media-video/bbtools/bbtools-1.9.ebuild
new file mode 100644
index 000000000000..f824754bccb5
--- /dev/null
+++ b/media-video/bbtools/bbtools-1.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="bbdmux, bbinfo, bbvinfo and bbainfo from Brent Beyeler"
+HOMEPAGE="http://members.cox.net/beyeler/bbmpeg.html"
+SRC_URI="http://files.digital-digest.com/downloads/files/encode/bbtool${PV/./}_src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ mv BBINFO.cpp bbinfo.cpp || die
+ mv BITS.CPP bits.cpp || die
+ mv BITS.H bits.h || die
+ mv bbdmux.CPP bbdmux.cpp || die
+ rm *.ide
+ edos2unix *.cpp *.h
+
+ epatch "${FILESDIR}"/bbtools-${PV}-gentoo.patch
+
+ append-lfs-flags
+ tc-export CXX
+}
+
+src_install() {
+ dobin bbainfo bbdmux bbinfo bbvinfo
+}