summaryrefslogtreecommitdiff
path: root/media-video/bbtools/bbtools-1.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /media-video/bbtools/bbtools-1.9.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'media-video/bbtools/bbtools-1.9.ebuild')
-rw-r--r--media-video/bbtools/bbtools-1.9.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/media-video/bbtools/bbtools-1.9.ebuild b/media-video/bbtools/bbtools-1.9.ebuild
index f824754bccb5..392e8c0d3afe 100644
--- a/media-video/bbtools/bbtools-1.9.ebuild
+++ b/media-video/bbtools/bbtools-1.9.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
inherit eutils flag-o-matic toolchain-funcs
@@ -12,22 +12,25 @@ SRC_URI="http://files.digital-digest.com/downloads/files/encode/bbtool${PV/./}_s
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-DEPEND="app-arch/unzip"
+BDEPEND="app-arch/unzip"
S=${WORKDIR}
+PATCHES=( "${FILESDIR}"/bbtools-${PV}-gentoo.patch )
+
src_prepare() {
mv BBINFO.cpp bbinfo.cpp || die
mv BITS.CPP bits.cpp || die
mv BITS.H bits.h || die
mv bbdmux.CPP bbdmux.cpp || die
- rm *.ide
+ rm *.ide || die
edos2unix *.cpp *.h
- epatch "${FILESDIR}"/bbtools-${PV}-gentoo.patch
+ default
+}
+src_configure() {
append-lfs-flags
tc-export CXX
}