summaryrefslogtreecommitdiff
path: root/media-sound
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-26 11:27:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-26 11:27:54 +0100
commit25e2c97a4a6f12a367115508fc86d34fe76a6f5e (patch)
tree68acc191d796190f572dc374002717fec321e616 /media-sound
parent1aa38370b2506ce90ad64cd4e18968d6612ebea5 (diff)
gentoo auto-resync : 26:09:2023 - 11:27:54
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/Manifest.gzbin57433 -> 57428 bytes
-rw-r--r--media-sound/fluidsynth/Manifest2
-rw-r--r--media-sound/fluidsynth/fluidsynth-2.3.4.ebuild121
3 files changed, 123 insertions, 0 deletions
diff --git a/media-sound/Manifest.gz b/media-sound/Manifest.gz
index fb613cfbcc5c..e05ec606508d 100644
--- a/media-sound/Manifest.gz
+++ b/media-sound/Manifest.gz
Binary files differ
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index 09cfda9dc93a..68275f65353d 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1,3 +1,5 @@
DIST fluidsynth-2.3.3.tar.gz 1774806 BLAKE2B 718d64a75cad7f589008b023942425b9c8c2f72b82ad9d554723c44d7af14adf1455404187904d6474cda5ebeb1c8aeb4eba55a73b4cb92b16b905923627827f SHA512 702b80ff9c8e2ba9fadd46a0377a295be78900c831ec4b6b75c2f5fee7e453b2e1f5511b076ccc044be7e6eb87086230c50c317dad3597a16d610e16032410fc
+DIST fluidsynth-2.3.4.tar.gz 1775291 BLAKE2B 5146c1f0243ac1fcc3d4f29ea65bb03b326c59bf9de1f53def447f4a924c7fdde31f8b33300051d2e7765087fb8bbdba3643b03c537e3366b02ca42b3b9d4311 SHA512 79891116d78b9be1c38bce9e5759b9bb732c3d8ee31c6e57d1a3e2b5548879b91d19582e73ee7fb0fd243beba3bf1bbc341a26aab0b6440eef36fc55dce3e8b0
EBUILD fluidsynth-2.3.3.ebuild 3449 BLAKE2B b2ddca5f6489b1012a5a93efe66efc98dd7bd053035df8fd06485ab499ef80e3e92b044777c2d2286ef9903a308d827f7df03c9cd8c1129a884afbf5db3d0870 SHA512 e9c73af7827752d62dccfbfd795a7fc20b7e6a011bf375bb5e678db1d4d84106072013873b0865e51ddfb6a01eeaa98dd24bddb65115935c13bd089db297a632
+EBUILD fluidsynth-2.3.4.ebuild 3456 BLAKE2B 67b7c63df7e11cb77fd646f2ad8df209397305349fa7a05596fe97fe3ba2f99afa59bbfc2414585622d609616047e848de3bf5f0b3023203f05dcda590a0e609 SHA512 042c16eb99dc9f0324dd44ff59119adfde7108617eea80c8581b27a4adf99be0935123a25ca547fd7e0c06935c67a2aa3fc86c8d47044b2be54779b34c0c6805
MISC metadata.xml 509 BLAKE2B f94b91d9486a14757aa47e69269d6321fb330556f24ac0d2d47d7734bc28164d9cff5d7ff7728aa6d59606006bc4bfa090662b9dd087a6bf36ae23660604938a SHA512 7bf5aeb69570ef736dc6a1a3d652449b0142978ee5e6ed9902d4f851deea87c8fb94bee821ee9ae93bc529411f336288021718490e86c2815de5d30111bd3b28
diff --git a/media-sound/fluidsynth/fluidsynth-2.3.4.ebuild b/media-sound/fluidsynth/fluidsynth-2.3.4.ebuild
new file mode 100644
index 000000000000..96eb1a12684c
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-2.3.4.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib systemd toolchain-funcs
+
+DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
+HOMEPAGE="https://www.fluidsynth.org"
+SRC_URI="https://github.com/FluidSynth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="alsa dbus debug examples ipv6 jack ladspa lash network oss pipewire portaudio pulseaudio +readline sdl +sndfile systemd threads"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ alsa? (
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ lash? ( media-sound/lash[${MULTILIB_USEDEP}] )
+ )
+ dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ ladspa? (
+ media-libs/ladspa-sdk[${MULTILIB_USEDEP}]
+ media-plugins/cmt-plugins[${MULTILIB_USEDEP}]
+ )
+ pipewire? (
+ media-video/pipewire:0=[${MULTILIB_USEDEP}]
+ )
+ portaudio? ( media-libs/portaudio[${MULTILIB_USEDEP}] )
+ pulseaudio? ( media-libs/libpulse[${MULTILIB_USEDEP}] )
+ readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
+ sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
+ sndfile? ( media-libs/libsndfile[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.md THANKS TODO doc/fluidsynth-v20-devdoc.txt )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_C_COMPILER="$(tc-getCC)"
+ -Denable-alsa=$(usex alsa)
+ -Denable-aufile=ON
+ -Denable-dbus=$(usex dbus)
+ -Denable-dsound=OFF # Windows
+ -Denable-floats=OFF # loat instead of double for DSP samples
+ -Denable-fpe-check=$(usex debug)
+ -Denable-ipv6=$(usex ipv6)
+ -Denable-jack=$(usex jack)
+ -Denable-ladspa=$(usex ladspa)
+ -Denable-libinstpatch=ON # https://github.com/swami/libinstpatch
+ -Denable-midishare=OFF # http://midishare.sourceforge.net/
+ -Denable-network=$(usex network)
+ -Denable-opensles=OFF
+ -Denable-oboe=OFF # requires OpenSLES and/or AAudio
+ -Denable-oss=$(usex oss)
+ -Denable-libsndfile=$(usex sndfile)
+ -Denable-portaudio=$(usex portaudio)
+ -Denable-profiling=$(usex debug)
+ -Denable-pulseaudio=$(usex pulseaudio)
+ -Denable-pipewire=$(usex pipewire)
+ -Denable-readline=$(usex readline)
+ -Denable-sdl2=$(usex sdl)
+ -Denable-systemd=$(usex systemd)
+ -Denable-threads=$(usex threads)
+ -Denable-trap-on-fpe=$(usex debug)
+ -Denable-ubsan=OFF # compile and link against UBSan (for debugging fluidsynth internals)
+ -Denable-waveout=OFF # Windows
+ -Denable-winmidi=OFF # Windows
+ )
+
+ if use alsa; then
+ mycmakeargs+=( -Denable-lash=$(usex lash) )
+ else
+ mycmakeargs+=( -Denable-lash=OFF )
+ fi
+
+ if use systemd; then
+ mycmakeargs+=( -DFLUID_DAEMON_ENV_FILE="/etc/fluidsynth.conf" )
+ fi
+
+ cmake-multilib_src_configure
+}
+
+install_systemd_files() {
+ if multilib_is_native_abi; then
+ systemd_dounit "${BUILD_DIR}/fluidsynth.service"
+ insinto /etc
+ doins "${BUILD_DIR}/fluidsynth.conf"
+ fi
+}
+
+multilib_src_test() {
+ eninja check
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ docinto pdf
+ dodoc doc/*.pdf
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+
+ if use systemd; then
+ multilib_foreach_abi install_systemd_files
+
+ elog "When using fluidsynth as a systemd service, make sure"
+ elog "to configure your fluidsynth settings globally in "
+ elog "/etc/fluidsynth.conf or per-user in ~/.config/fluidsynth"
+ fi
+}