summaryrefslogtreecommitdiff
path: root/media-sound
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-19 07:47:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-19 07:47:44 +0000
commitfcefa9aa213e0ff26901b351fccd47393113ae5d (patch)
tree16ff06e1d47c8dc06b954f726f24cd6f941e3596 /media-sound
parent8bb75334c4b9f91e9f95784e986ed31b4bc11f92 (diff)
gentoo auto-resync : 19:12:2022 - 07:47:44
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/Manifest.gzbin56889 -> 56889 bytes
-rw-r--r--media-sound/clementine/Manifest3
-rw-r--r--media-sound/clementine/clementine-1.4.0_rc2-r1.ebuild165
-rw-r--r--media-sound/clementine/clementine-9999.ebuild2
4 files changed, 167 insertions, 3 deletions
diff --git a/media-sound/Manifest.gz b/media-sound/Manifest.gz
index 167d3613002f..0815c4e43f8d 100644
--- a/media-sound/Manifest.gz
+++ b/media-sound/Manifest.gz
Binary files differ
diff --git a/media-sound/clementine/Manifest b/media-sound/clementine/Manifest
index 5b114fd3e119..6182413d7920 100644
--- a/media-sound/clementine/Manifest
+++ b/media-sound/clementine/Manifest
@@ -1,4 +1,5 @@
DIST clementine-1.4.0_rc2.tar.gz 9073685 BLAKE2B a2376f1a895c651c2eb089419e20b9ce6050739f1342a6fdf1ebad0a14b65a08f56cc846eb79ad7facb77d6ee2cac74f9e374bd8e284a2a7f87d7c117779a08d SHA512 403093386efabd52e649c0e379abbf4873c4b2f8d0af72cda2b7e0255f90c60259f961045e7b51d0e5bf35425d678ff6b018c9191845ebbd156d9216d8bd7722
+EBUILD clementine-1.4.0_rc2-r1.ebuild 4583 BLAKE2B 883bb18c304f16f0d9ef1ab39e298f14047687a63fcb96cb444a96201aab0059c03335f0265897d5b425761f30363e6607c811de703a770af2a8052b728a833f SHA512 fbccb18fc5c675180975ce076093b287da56af22c3ca400902ceed2efe09135654df39412e890001a28a0715a286b895a7f26dc2c900e286c9f985f1b05771d8
EBUILD clementine-1.4.0_rc2.ebuild 4558 BLAKE2B 223403e458f81593ae949508af89828f82d6938b04d42a29caebce70f899f1bb80d5c1d1e64f8f379ce5ea1d9deabb09d534aa1585179544c67862da754bbb6f SHA512 c8550c75dffddf2c617a1f3104641947abb31e7935fd6225d87a81b28af3d8d7a6ec0e6db6e2d7ee81835251d573635c9dcfc9d5271b8229d06af43fdf631e60
-EBUILD clementine-9999.ebuild 4560 BLAKE2B bdf832ce35ef4f0ea23f9ece7b9d676fd35a4f84a5a13d0913e22a923efd724f3746a866bb4a3fc06b83edd68371247ddc31e5e3c11c794fb0023214b992b3c2 SHA512 5efe80cfcf9c56d55e40e061400fa9b8077c9617ec1f9f50ba1b9fc14795be6bd362af787177a78ab7ca951b4a539f7c53d56dee700901fc0da87500eea7eea6
+EBUILD clementine-9999.ebuild 4503 BLAKE2B 68f416ad5298ab06c25ccf1a5559d411c8817b0d78efe0ff69b2595996fe2118b217c98f0d43cf5461b60613f91c3ab0d8d3def3ccbb3db260a361ff48e746af SHA512 f0e5056f12cf3bfe8bac02b35526bbcf41b79434adfbb53f1b411093046e54c48b839f65957d8278ecaf4f0c89e52db4139a199a0f6d739a0858da5ed910563c
MISC metadata.xml 1205 BLAKE2B 385d0f742772f036d1d0e03913aa1e38fe165dfeec7a6773fa5685992f9bbc348437bd759c24c54686d19f8dfbadc8bf208909788bc1e0dd957e47bb659fb832 SHA512 58d908699a52724401f167ae20fa05327aa4fd5b705856a43292c98e898b2f13d11c9db6fac6def35eede0c356071ff38e22883ca233a1005173ded18e69ca92
diff --git a/media-sound/clementine/clementine-1.4.0_rc2-r1.ebuild b/media-sound/clementine/clementine-1.4.0_rc2-r1.ebuild
new file mode 100644
index 000000000000..68143124af82
--- /dev/null
+++ b/media-sound/clementine/clementine-1.4.0_rc2-r1.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Modern music player and library organizer based on Amarok 1.4 and Qt"
+HOMEPAGE="https://www.clementine-player.org https://github.com/clementine-player/Clementine"
+
+PLOCALES="af ar be bg bn br bs ca cs cy da de el en en_CA en_GB eo es et eu fa fi fr ga gl he he_IL hi hr hu hy ia id is it ja ka kk ko lt lv mk_MK mr ms my nb nl oc pa pl pt pt_BR ro ru si_LK sk sl sr sr@latin sv te tr tr_TR uk uz vi zh_CN zh_TW"
+
+inherit cmake flag-o-matic plocale virtualx xdg
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/clementine-player/Clementine.git"
+ inherit git-r3
+else
+ S="${WORKDIR}/Clementine-${PV/_}"
+ SRC_URI="https://github.com/clementine-player/Clementine/archive/refs/tags/${PV/_}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="alsa box cdda +dbus debug dropbox googledrive ipod lastfm mms moodbar mtp projectm pulseaudio seafile skydrive test +udisks wiimote"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ udisks? ( dbus )
+ wiimote? ( dbus )
+"
+
+BDEPEND="
+ >=dev-cpp/gtest-1.8.0
+ dev-qt/linguist-tools:5
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? (
+ dev-qt/qttest:5
+ gnome-base/gsettings-desktop-schemas
+ )
+"
+COMMON_DEPEND="
+ dev-db/sqlite:3
+ dev-libs/crypto++:=
+ dev-libs/glib:2
+ dev-libs/protobuf:=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/chromaprint:=
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=media-libs/libmygpo-qt-1.0.9[qt5(+)]
+ >=media-libs/taglib-1.11.1_p20181028
+ sys-libs/zlib
+ x11-libs/libX11
+ alsa? ( media-libs/alsa-lib )
+ cdda? ( dev-libs/libcdio:= )
+ dbus? ( dev-qt/qtdbus:5 )
+ ipod? ( >=media-libs/libgpod-0.8.0 )
+ lastfm? ( >=media-libs/liblastfm-1.1.0_pre20150206 )
+ moodbar? ( sci-libs/fftw:3.0= )
+ mtp? ( >=media-libs/libmtp-1.0.0 )
+ projectm? (
+ media-libs/glew:=
+ >=media-libs/libprojectm-3.1.12:0=
+ virtual/opengl
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/gst-plugins-soup:1.0
+ media-plugins/gst-plugins-taglib:1.0
+ mms? ( media-plugins/gst-plugins-libmms:1.0 )
+ mtp? ( gnome-base/gvfs[mtp] )
+ udisks? ( sys-fs/udisks:2 )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ dev-libs/libxml2
+ dev-qt/qtopengl:5
+ dev-qt/qtxml:5
+ virtual/glu
+ box? ( dev-cpp/sparsehash )
+ dropbox? ( dev-cpp/sparsehash )
+ googledrive? ( dev-cpp/sparsehash )
+ pulseaudio? ( media-sound/pulseaudio )
+ seafile? ( dev-cpp/sparsehash )
+ skydrive? ( dev-cpp/sparsehash )
+"
+
+DOCS=( Changelog README.md )
+
+src_prepare() {
+ plocale_find_changes "src/translations" "" ".po"
+
+ cmake_src_prepare
+ # some tests fail or hang
+ sed -i \
+ -e '/add_test_file(translations_test.cpp/d' \
+ tests/CMakeLists.txt || die
+
+ if ! use test; then
+ sed -e "/find_package.*Qt5/s:\ Test::" -i CMakeLists.txt || die
+ cmake_comment_add_subdirectory tests
+ fi
+
+ rm -r 3rdparty/{libmygpo-qt,libmygpo-qt5,taglib} || die
+}
+
+src_configure() {
+ # spotify is not in portage
+ local mycmakeargs=(
+ -DBUILD_WERROR=OFF
+ # force to find crypto++ see bug #548544
+ -DCRYPTOPP_LIBRARIES="cryptopp"
+ -DCRYPTOPP_FOUND=ON
+ # avoid automagically enabling of ccache (bug #611010)
+ -DCCACHE_EXECUTABLE=OFF
+ -DENABLE_BREAKPAD=OFF #< disable crash reporting
+ -DENABLE_GIO=ON
+ -DENABLE_SPOTIFY=OFF
+ -DENABLE_SPOTIFY_BLOB=OFF
+ -DUSE_SYSTEM_GMOCK=ON
+ -DUSE_SYSTEM_PROJECTM=ON
+ -DBUNDLE_PROJECTM_PRESETS=OFF
+ -DLINGUAS="$(plocale_get_locales)"
+ -DENABLE_BOX="$(usex box)"
+ -DENABLE_AUDIOCD="$(usex cdda)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5DBus=$(usex !dbus)
+ -DENABLE_DROPBOX="$(usex dropbox)"
+ -DENABLE_GOOGLE_DRIVE="$(usex googledrive)"
+ -DENABLE_LIBGPOD="$(usex ipod)"
+ -DENABLE_LIBLASTFM="$(usex lastfm)"
+ -DENABLE_MOODBAR="$(usex moodbar)"
+ -DENABLE_LIBMTP="$(usex mtp)"
+ -DENABLE_VISUALISATIONS="$(usex projectm)"
+ -DENABLE_SEAFILE="$(usex seafile)"
+ -DENABLE_SKYDRIVE="$(usex skydrive)"
+ -DENABLE_LIBPULSE="$(usex pulseaudio)"
+ -DENABLE_UDISKS2="$(usex udisks)"
+ -DENABLE_WIIMOTEDEV="$(usex wiimote)"
+ )
+
+ use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${CMAKE_BUILD_DIR}" || die
+ virtx cmake_build clementine_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "Note that list of supported formats is controlled by media-plugins/gst-plugins-meta "
+ elog "USE flags. You may be interested in setting aac, flac, mp3, ogg or wavpack USE flags "
+ elog "depending on your preferences"
+}
diff --git a/media-sound/clementine/clementine-9999.ebuild b/media-sound/clementine/clementine-9999.ebuild
index 8ae86de1f1b4..395332d8f569 100644
--- a/media-sound/clementine/clementine-9999.ebuild
+++ b/media-sound/clementine/clementine-9999.ebuild
@@ -113,7 +113,6 @@ src_prepare() {
}
src_configure() {
- # spotify is not in portage
local mycmakeargs=(
-DBUILD_WERROR=OFF
# force to find crypto++ see bug #548544
@@ -123,7 +122,6 @@ src_configure() {
-DCCACHE_EXECUTABLE=OFF
-DENABLE_BREAKPAD=OFF #< disable crash reporting
-DENABLE_GIO=ON
- -DENABLE_SPOTIFY_BLOB=OFF
-DUSE_SYSTEM_GMOCK=ON
-DUSE_SYSTEM_PROJECTM=ON
-DBUNDLE_PROJECTM_PRESETS=OFF