summaryrefslogtreecommitdiff
path: root/media-sound/vorbis-tools/vorbis-tools-1.4.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /media-sound/vorbis-tools/vorbis-tools-1.4.2-r2.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'media-sound/vorbis-tools/vorbis-tools-1.4.2-r2.ebuild')
-rw-r--r--media-sound/vorbis-tools/vorbis-tools-1.4.2-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/vorbis-tools/vorbis-tools-1.4.2-r2.ebuild b/media-sound/vorbis-tools/vorbis-tools-1.4.2-r2.ebuild
new file mode 100644
index 000000000000..88fbe65aadc1
--- /dev/null
+++ b/media-sound/vorbis-tools/vorbis-tools-1.4.2-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Tools for using the Ogg Vorbis sound file format"
+HOMEPAGE="https://xiph.org/vorbis/"
+SRC_URI="https://ftp.osuosl.org/pub/xiph/releases/vorbis/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="flac kate nls +ogg123 speex"
+
+RDEPEND="
+ media-libs/libvorbis
+ media-libs/opusfile
+ flac? ( media-libs/flac:= )
+ kate? ( media-libs/libkate )
+ ogg123? (
+ media-libs/libao
+ net-misc/curl
+ )
+ speex? ( media-libs/speex )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-docdir.patch
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with flac)
+ $(use_with kate)
+ $(use_enable nls)
+ $(use_enable ogg123)
+ $(use_with speex)
+ )
+ econf "${myeconfargs[@]}"
+}