summaryrefslogtreecommitdiff
path: root/media-sound/vb2rip/vb2rip-1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/vb2rip/vb2rip-1.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/vb2rip/vb2rip-1.4.ebuild')
-rw-r--r--media-sound/vb2rip/vb2rip-1.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-sound/vb2rip/vb2rip-1.4.ebuild b/media-sound/vb2rip/vb2rip-1.4.ebuild
new file mode 100644
index 000000000000..00678f566df4
--- /dev/null
+++ b/media-sound/vb2rip/vb2rip-1.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit versionator toolchain-funcs
+
+MY_PV=$(replace_version_separator '')
+
+DESCRIPTION="Konami VB2 sound format ripping utility"
+HOMEPAGE="http://www.neillcorlett.com/vb2rip"
+SRC_URI="http://www.neillcorlett.com/vb2rip/${PN}${MY_PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/src
+
+src_compile() {
+ tc-export CC
+ echo "vb2rip: main.o decode.o wav.o lsb.o rip.o fmt.o fmt_raw.o fmt_vb2.o fmt_8.o fmt_msa.o fmt_xa2.o" > Makefile
+ echo ' $(CC) $(LDFLAGS) $^ -o $@' >> Makefile
+ emake || die
+}
+
+src_install() {
+ dobin vb2rip || die
+ dodoc "${WORKDIR}/games.txt" "${WORKDIR}/vb2rip.txt"
+}