summaryrefslogtreecommitdiff
path: root/media-sound/tunapie/tunapie-2.1.17-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/tunapie/tunapie-2.1.17-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/tunapie/tunapie-2.1.17-r1.ebuild')
-rw-r--r--media-sound/tunapie/tunapie-2.1.17-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-sound/tunapie/tunapie-2.1.17-r1.ebuild b/media-sound/tunapie/tunapie-2.1.17-r1.ebuild
new file mode 100644
index 000000000000..db38951688e3
--- /dev/null
+++ b/media-sound/tunapie/tunapie-2.1.17-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1
+
+DESCRIPTION="Directory browser for Radio and TV streams"
+HOMEPAGE="http://tunapie.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="offensive"
+
+RDEPEND=">=dev-python/wxpython-2.6[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ default
+
+ # fix pixmap lookup
+ sed -i -e 's@../pixmaps@../../share/pixmaps@' \
+ src/tunapie2_main.py || die
+
+ # the original script requires more sed than code,
+ cat > tunapie <<-_EOF_ || die
+ #!/bin/sh
+ exec ${EPYTHON} /usr/lib/tunapie/Tunapie.py
+ _EOF_
+}
+
+src_install() {
+ dobin tunapie
+ doman tunapie.1
+ dodoc CHANGELOG README
+
+ python_moduleinto /usr/lib/tunapie
+ python_domodule src/{*.py,*.png}
+
+ doicon src/tplogo.xpm
+ domenu tunapie.desktop
+
+ dodir /etc
+ usex offensive 1 0 > "${ED%/}"/etc/tunapie.config || die
+}