summaryrefslogtreecommitdiff
path: root/media-sound/toolame/toolame-02l-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/toolame/toolame-02l-r4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/toolame/toolame-02l-r4.ebuild')
-rw-r--r--media-sound/toolame/toolame-02l-r4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-sound/toolame/toolame-02l-r4.ebuild b/media-sound/toolame/toolame-02l-r4.ebuild
new file mode 100644
index 000000000000..685ff590e1c3
--- /dev/null
+++ b/media-sound/toolame/toolame-02l-r4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="tooLAME - an optimized mpeg 1/2 layer 2 audio encoder"
+HOMEPAGE="http://www.planckenergy.com"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-gentoo.diff"
+ "${FILESDIR}/${P}-uint.patch"
+ "${FILESDIR}/${P}-uint32_t.patch"
+)
+
+src_prepare() {
+ # fix #571774 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+
+ append-lfs-flags
+ tc-export CC
+
+ default
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README HISTORY FUTURE html/* text/*
+}