summaryrefslogtreecommitdiff
path: root/media-sound/toolame/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-sound/toolame/files
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-sound/toolame/files')
-rw-r--r--media-sound/toolame/files/toolame-02l-Makefile.patch (renamed from media-sound/toolame/files/toolame-02l-gentoo.diff)17
-rw-r--r--media-sound/toolame/files/toolame-02l-fno-common.patch20
2 files changed, 29 insertions, 8 deletions
diff --git a/media-sound/toolame/files/toolame-02l-gentoo.diff b/media-sound/toolame/files/toolame-02l-Makefile.patch
index f96020f0a815..28009555d858 100644
--- a/media-sound/toolame/files/toolame-02l-gentoo.diff
+++ b/media-sound/toolame/files/toolame-02l-Makefile.patch
@@ -1,5 +1,5 @@
---- toolame-02l/Makefile 2003-03-02 08:07:02.000000000 +0100
-+++ toolame-02l/Makefile.new 2003-04-14 14:00:10.000000000 +0200
+--- a/Makefile
++++ b/Makefile
@@ -1,6 +1,3 @@
-
-CC = gcc
@@ -7,7 +7,7 @@
c_sources = \
common.c \
encode.c \
-@@ -26,37 +23,16 @@
+@@ -26,29 +23,8 @@
OBJ = $(c_sources:.c=.o)
@@ -19,8 +19,8 @@
-OPTIM = -O3
-
# These flags are pretty much mandatory
- REQUIRED = -DNDEBUG -DINLINE=inline
-
+-REQUIRED = -DNDEBUG -DINLINE=inline
+-
-#pick your architecture
-ARCH = -march=pentium
-#Possible x86 architectures
@@ -34,15 +34,16 @@
-# -malign-double \
-# -mfancy-math-387 -funroll-loops -funroll-all-loops -pipe \
-# -fschedule-insns2 -fno-strength-reduce
--
++REQUIRED = -DNDEBUG -DINLINE=
+
#Set a stack of warnings to overcome my atrocious coding style . MFC.
WARNINGS = -Wall
- WARNINGS2 = -Wstrict-prototypes -Wmissing-prototypes -Wunused -Wunused-function -Wunused-label -Wunused-parameter -Wunused-variable -Wunused-value -Wredundant-decls
+@@ -56,7 +32,7 @@
NEW_02L_FIXES = -DNEWENCODE -DNEWATAN
-CC_SWITCHES = $(OPTIM) $(REQUIRED) $(ARCH) $(PG) $(TWEAKS) $(WARNINGS) $(NEW_02L_FIXES)
-+CC_SWITCHES = $(CFLAGS) $(REQUIRED) $(WARNINGS) $(NEW_02L_FIXES)
++CC_SWITCHES = $(CFLAGS) $(CPPFLAGS) $(REQUIRED) $(WARNINGS) $(NEW_02L_FIXES)
PGM = toolame
diff --git a/media-sound/toolame/files/toolame-02l-fno-common.patch b/media-sound/toolame/files/toolame-02l-fno-common.patch
new file mode 100644
index 000000000000..c414324785bb
--- /dev/null
+++ b/media-sound/toolame/files/toolame-02l-fno-common.patch
@@ -0,0 +1,20 @@
+--- a/common.c
++++ b/common.c
+@@ -19,6 +19,8 @@
+ *
+ ***********************************************************************/
+
++options glopts;
++
+ char *mode_names[4] = { "stereo", "j-stereo", "dual-ch", "single-ch" };
+ char *version_names[2] = { "MPEG-2 LSF", "MPEG-1" };
+
+--- a/options.h
++++ b/options.h
+@@ -19,5 +19,5 @@
+ }
+ options;
+
+-options glopts;
++extern options glopts;
+ #endif