summaryrefslogtreecommitdiff
path: root/media-sound/streamtranscoder/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/streamtranscoder/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/streamtranscoder/files')
-rw-r--r--media-sound/streamtranscoder/files/streamtranscoder-1.2.4-build.patch59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-sound/streamtranscoder/files/streamtranscoder-1.2.4-build.patch b/media-sound/streamtranscoder/files/streamtranscoder-1.2.4-build.patch
new file mode 100644
index 000000000000..d79b074abd9d
--- /dev/null
+++ b/media-sound/streamtranscoder/files/streamtranscoder-1.2.4-build.patch
@@ -0,0 +1,59 @@
+--- a/configure.in
++++ b/configure.in
+@@ -83,22 +83,29 @@
+
+ dnl -- configure options --
+
+-XIPH_PATH_OGG(, AC_MSG_ERROR(must have Ogg installed!(Perhaps you need --with-ogg-prefix=/usr/local)))
+-XIPH_PATH_VORBIS(, AC_MSG_ERROR(must have Vorbis installed!(Perhaps you need --with-vorbis-prefix=/usr/local)))
+-AM_PATH_CURL(,,AC_MSG_ERROR(must have libcurl installed!))
+-AM_PATH_MAD(, AC_MSG_ERROR(must have libmad installed!))
+-AM_PATH_LAME(, AC_MSG_ERROR(must have libmp3lame installed!))
++PKG_CHECK_MODULES([OGG],[ogg])
++PKG_CHECK_MODULES([VORBIS],[vorbis])
++PKG_CHECK_MODULES([VORBISENC],[vorbisenc])
++PKG_CHECK_MODULES([VORBISFILE],[vorbisfile])
++PKG_CHECK_MODULES([CURL],[libcurl])
++PKG_CHECK_MODULES([MAD],[mad])
++
++AC_PATH_PROG([LAME],[lame])
+
+ dnl Make substitutions
+
+ AC_SUBST(MAD_CFLAGS)
+ AC_SUBST(MAD_LIBS)
+ AC_SUBST(LAME_CFLAGS)
+-AC_SUBST(LAME_LIBS)
++AC_SUBST([LAME_LIBS],[-lmp3lame])
+ AC_SUBST(OGG_CFLAGS)
+ AC_SUBST(VORBIS_CFLAGS)
++AC_SUBST(VORBISENC_CFLAGS)
++AC_SUBST(VORBISFILE_CFLAGS)
+ AC_SUBST(OGG_LIBS)
+ AC_SUBST(VORBIS_LIBS)
++AC_SUBST(VORBISENC_LIBS)
++AC_SUBST(VORBISFILE_LIBS)
+ AC_SUBST(LIBTOOL_DEPS)
+ AC_SUBST(OPT)
+ AC_SUBST(LIBS)
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -17,5 +17,6 @@
+
+ INCLUDES = -I$(srcdir)/liboddcast -I$(srcdir)/libtranscoder
+
+-install-hook:
+- cp transcoder.cfg $(DESTDIR)$(sysconfdir)/transcoder.cfg
++install-data-hook:
++ $(INSTALL) -d $(DESTDIR)$(sysconfdir)
++ $(INSTALL) -m644 transcoder.cfg $(DESTDIR)$(sysconfdir)/transcoder.cfg
+--- a/src/libtranscoder/transcurl.cpp
++++ b/src/libtranscoder/transcurl.cpp
+@@ -18,7 +18,6 @@
+ #include <winsock2.h>
+ #endif
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+ #include "transcurl.h"
+ #include "cbuffer.h"