summaryrefslogtreecommitdiff
path: root/media-sound/streamripper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-10 00:01:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-10 00:01:14 +0100
commit17e5f1ea4a2e1c5664f96480ca46348d008e8711 (patch)
tree7166d1b58a582290a4ad23ff5882cca911b8035c /media-sound/streamripper
parenta0ce545d52f231499bf9f3644493113d8af58ec9 (diff)
gentoo auto-resync : 10:05:2024 - 00:01:13
Diffstat (limited to 'media-sound/streamripper')
-rw-r--r--media-sound/streamripper/Manifest2
-rw-r--r--media-sound/streamripper/files/streamripper-1.64.6-fix-c99.patch44
-rw-r--r--media-sound/streamripper/streamripper-1.64.6-r1.ebuild45
3 files changed, 91 insertions, 0 deletions
diff --git a/media-sound/streamripper/Manifest b/media-sound/streamripper/Manifest
index 68231312d223..5f53c5d0efd7 100644
--- a/media-sound/streamripper/Manifest
+++ b/media-sound/streamripper/Manifest
@@ -1,4 +1,6 @@
AUX streamripper-1.64.6-fix-autotools.patch 260 BLAKE2B b216a7a62c3c1ec53e98b85f47c7e3b07746dbb3483de7de0b1f9face420395abc10f1205624e92eede1247e4c75785b3797a6ec373ada26f876d6a8cb45acbb SHA512 49714d3ea1db143771a2ebcfd3ddd08a60e6eb63fd1e2a0b676b2d0c359b25ebd9dd40510c0137e24ef7c44c718cc83843535fae00325a098f4f1542e18e6f67
+AUX streamripper-1.64.6-fix-c99.patch 1123 BLAKE2B 3e9c0e358cdccf7df935e1247a32a1b834ce0494bd210aec20000511085667634656ed9a8b21b3731c963aa7de5805b90ca569e2c4ff67ce1c95c1b47dbdc7d1 SHA512 6569b16e8656e24a2d424fd5a5c013e5dabfae5bf8a9f8025cae9062172a4dd317ce192623c8043a8a9faa3fc6a2853831012717496634049b99f9ff7f7bcc6d
DIST streamripper-1.64.6.tar.gz 900205 BLAKE2B b316565c786b2005802b24cb441d6ee73c2548a4ac7515633fd92faba143a4708bc49c9de7c3eb9985de14a43ac1f86935ac2c353e3d14a7cbf28e334fa21338 SHA512 8477086d0099f6de861f1c47112476c427073b6e8127bbaaa2dd3e7930fe9a5c6d9b2c68d4a317f1bc0b20c625e665d5c245189049d35468aa83cf51828d4428
+EBUILD streamripper-1.64.6-r1.ebuild 915 BLAKE2B 659e7d1843e74abb543ea3b763141bafc8d6fe37fc3f85a0b9e1e8af6a30325cdc90c961cce09d8fdd0b1cc39c549185b4bc5459c916152ff67d2c7f67940a11 SHA512 6c54cd180d6aa918ec49f85822aac419a68e12a9911838934d569e54592db1b9d7362097cd67c031714c16e5923cf0c77b81c4d991170b8b799311d6787e9883
EBUILD streamripper-1.64.6.ebuild 875 BLAKE2B 9681460e4d97fab1cb862b1cc73735083f9f883d3c99816dbf16ef5595541658658fd02d4c1f5be69957c843ea21660b768910dc7a589d7fa77be3e5b2776cb2 SHA512 ef511d36b8d52fb0afbb8e53b7ebb64160b6512a839160bd74bfb3a5fb33377e462c24c519c125a669ad60f37e17265cae7adb055a89098f2b5c9c05f031a8cc
MISC metadata.xml 346 BLAKE2B 676b46ee59507f6893d33744c01d5864fa50923718eb8907db92b05b2ee9449ddd2514c378d8dbe715a82e26633c7d370a62fc0414a4c2924c5a6cf950701167 SHA512 71db384aebbce86d8f5c01eeacd3064aa31678026e0d54a57e9eaf0080c0ac450d54fe4f9fc036b7225147b7483def87cd2e29b7dedb921696a59116fc4cce4d
diff --git a/media-sound/streamripper/files/streamripper-1.64.6-fix-c99.patch b/media-sound/streamripper/files/streamripper-1.64.6-fix-c99.patch
new file mode 100644
index 000000000000..60fb15da9433
--- /dev/null
+++ b/media-sound/streamripper/files/streamripper-1.64.6-fix-c99.patch
@@ -0,0 +1,44 @@
+We live in modern world and have ANSI C here. Plus, nothing defines ANSI_PROTOTYPES
+Include unconditionally
+
+Closes: https://bugs.gentoo.org/713314
+Closes: https://bugs.gentoo.org/896432
+--- a/lib/argv.c
++++ b/lib/argv.c
+@@ -52,25 +52,10 @@
+
+ /* Routines imported from standard C runtime libraries. */
+
+-#ifdef ANSI_PROTOTYPES
+-
+ #include <stddef.h>
+ #include <string.h>
+ #include <stdlib.h>
+
+-#else /* !ANSI_PROTOTYPES */
+-
+-#if !defined _WIN32 || defined __GNUC__
+-extern char *memcpy (); /* Copy memory region */
+-extern int strlen (); /* Count length of string */
+-extern char *malloc (); /* Standard memory allocater */
+-extern char *realloc (); /* Standard memory reallocator */
+-extern void free (); /* Free malloc'd memory */
+-extern char *strdup (); /* Duplicate a string */
+-#endif
+-
+-#endif /* ANSI_PROTOTYPES */
+-
+
+ #ifndef NULL
+ #define NULL 0
+--- a/lib/ripstream.c
++++ b/lib/ripstream.c
+@@ -714,7 +714,7 @@
+ char bigbuf[HEADER_SIZE] = "";
+ ID3V2frame id3v2frame;
+ #ifndef WIN32
+- __uint32_t framesize = 0;
++ uint32_t framesize = 0;
+ #else
+ unsigned long int framesize = 0;
+ #endif
diff --git a/media-sound/streamripper/streamripper-1.64.6-r1.ebuild b/media-sound/streamripper/streamripper-1.64.6-r1.ebuild
new file mode 100644
index 000000000000..1efacf79082f
--- /dev/null
+++ b/media-sound/streamripper/streamripper-1.64.6-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Extracts and records individual MP3 file tracks from shoutcast streams"
+HOMEPAGE="https://streamripper.sourceforge.net"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="vorbis"
+
+RDEPEND="
+ media-libs/libmad
+ media-libs/faad2
+ >=dev-libs/glib-2.16
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-autotools.patch
+ "${FILESDIR}"/${P}-fix-c99.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-included-libmad \
+ --without-included-argv \
+ $(use_with vorbis ogg)
+}
+
+src_install() {
+ default
+ dodoc parse_rules.txt
+}