summaryrefslogtreecommitdiff
path: root/media-sound/spek/spek-0.8.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-26 08:58:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-26 08:58:19 +0100
commit34ce8f465101950c92cb66c657d3244b5a8397db (patch)
tree5df8a8c3a293be4942f5df9f9cd81babb70fac96 /media-sound/spek/spek-0.8.4.ebuild
parent24162508832f37f873ab12dfdfb191cf99318055 (diff)
gentoo auto-resync : 26:07:2022 - 08:58:19
Diffstat (limited to 'media-sound/spek/spek-0.8.4.ebuild')
-rw-r--r--media-sound/spek/spek-0.8.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/spek/spek-0.8.4.ebuild b/media-sound/spek/spek-0.8.4.ebuild
new file mode 100644
index 000000000000..dbfa6ab4d593
--- /dev/null
+++ b/media-sound/spek/spek-0.8.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit wxwidgets xdg
+
+DESCRIPTION="Analyse your audio files by showing their spectrogram"
+HOMEPAGE="http://www.spek-project.org/"
+SRC_URI="https://github.com/alexkay/spek/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ media-video/ffmpeg:=
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.4-disable-updates.patch
+)
+
+src_configure() {
+ setup-wxwidgets unicode
+ default
+}