summaryrefslogtreecommitdiff
path: root/media-sound/spek/spek-0.8.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /media-sound/spek/spek-0.8.3-r1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'media-sound/spek/spek-0.8.3-r1.ebuild')
-rw-r--r--media-sound/spek/spek-0.8.3-r1.ebuild45
1 files changed, 22 insertions, 23 deletions
diff --git a/media-sound/spek/spek-0.8.3-r1.ebuild b/media-sound/spek/spek-0.8.3-r1.ebuild
index 4c60f5cbe8a1..be7cff895114 100644
--- a/media-sound/spek/spek-0.8.3-r1.ebuild
+++ b/media-sound/spek/spek-0.8.3-r1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
WX_GTK_VER="3.0"
-inherit autotools eutils toolchain-funcs wxwidgets
+inherit autotools wxwidgets xdg
DESCRIPTION="Analyse your audio files by showing their spectrogram"
HOMEPAGE="http://www.spek-project.org/"
@@ -16,30 +17,28 @@ KEYWORDS="~amd64"
RDEPEND="
media-video/ffmpeg:0=
- x11-libs/wxGTK:${WX_GTK_VER}[X]
-"
-DEPEND="${RDEPEND}
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-util/intltool
- virtual/pkgconfig
- >=sys-devel/gcc-4.7
sys-devel/gettext
-"
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.1-disable-updates.patch
+ "${FILESDIR}"/${P}-replace-gnu+11-with-c++11.patch
+ "${FILESDIR}"/${P}-stdlib.patch
+ "${FILESDIR}"/${P}-ffmpeg3.patch
+ "${FILESDIR}"/${P}-ffmpeg3-1.patch
+ "${FILESDIR}"/${P}-AR.patch
+)
src_prepare() {
- need-wxwidgets unicode
-
- if [ $(gcc-major-version) -lt "4" ] ; then
- die "You need to activate at least gcc:4.7"
- fi
- if [ $(gcc-major-version) -eq "4" -a $(gcc-minor-version) -lt "7" ] ; then
- die "You need to activate at least gcc:4.7"
- fi
-
- epatch \
- "${FILESDIR}"/${PN}-0.8.1-disable-updates.patch \
- "${FILESDIR}"/${P}-replace-gnu+11-with-c++11.patch \
- "${FILESDIR}"/${P}-stdlib.patch \
- "${FILESDIR}"/${P}-ffmpeg3.patch \
- "${FILESDIR}"/${P}-ffmpeg3-1.patch
+ default
eautoreconf
}
+
+src_configure() {
+ setup-wxwidgets unicode
+ default
+}