summaryrefslogtreecommitdiff
path: root/media-sound/spek/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-24 16:33:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-24 16:33:11 +0000
commitfaddeff65d652bda3291eba255955adb17f1aa19 (patch)
tree4352e6d85ce48c7c8d96159fad4d3dd90602a70a /media-sound/spek/files
parent0e7b1da874d923b9f006e0000023f5fa528140a8 (diff)
gentoo auto-resync : 24:11:2023 - 16:33:11
Diffstat (limited to 'media-sound/spek/files')
-rw-r--r--media-sound/spek/files/00_dfsg.patch19
-rw-r--r--media-sound/spek/files/01_arm64-mips64el.patch15
-rw-r--r--media-sound/spek/files/02_ftbfs-gcc13.patch10
-rw-r--r--media-sound/spek/files/03_metainfo.patch66
-rw-r--r--media-sound/spek/files/spek-0.8.1-disable-updates.patch11
-rw-r--r--media-sound/spek/files/spek-0.8.3-AR.patch18
-rw-r--r--media-sound/spek/files/spek-0.8.3-ffmpeg3-1.patch33
-rw-r--r--media-sound/spek/files/spek-0.8.3-ffmpeg3.patch37
-rw-r--r--media-sound/spek/files/spek-0.8.3-replace-gnu+11-with-c++11.patch11
-rw-r--r--media-sound/spek/files/spek-0.8.3-stdlib.patch22
10 files changed, 110 insertions, 132 deletions
diff --git a/media-sound/spek/files/00_dfsg.patch b/media-sound/spek/files/00_dfsg.patch
new file mode 100644
index 000000000000..4384fc1f326d
--- /dev/null
+++ b/media-sound/spek/files/00_dfsg.patch
@@ -0,0 +1,19 @@
+Author: Matteo Bini <matteobin@tiepi.it>
+Description: Remove DFSG excluded files for Autoconf
+Forwarded: not-needed
+--- a/configure.ac
++++ b/configure.ac
+@@ -81,13 +81,10 @@ AC_CONFIG_FILES([
+ data/icons/32x32/Makefile
+ data/icons/48x48/Makefile
+ data/icons/scalable/Makefile
+- dist/osx/Info.plist
+- dist/win/spek.wxs
+ man/Makefile
+ po/Makefile.in
+ src/Makefile
+ tests/Makefile
+- web/version
+ ])
+ AC_OUTPUT
+
diff --git a/media-sound/spek/files/01_arm64-mips64el.patch b/media-sound/spek/files/01_arm64-mips64el.patch
new file mode 100644
index 000000000000..8d14a48b3b29
--- /dev/null
+++ b/media-sound/spek/files/01_arm64-mips64el.patch
@@ -0,0 +1,15 @@
+Author: Mike Wang <mikewang000000@gmail.com>
+Bug: https://github.com/alexkay/spek/issues/262
+Description: Fix FFT unit tests
+Forwarded: https://github.com/alexkay/spek/commit/0998df9a7ac99d509ddd10fb76d883f24efc0179
+--- a/tests/test-fft.cc
++++ b/tests/test-fft.cc
+@@ -62,7 +62,7 @@ static void test_sine()
+ if (i == k) {
+ continue;
+ }
+- if (plan->get_output(i) > -150.0f) {
++ if (plan->get_output(i) > -149.0f) {
+ silence = false;
+ break;
+ }
diff --git a/media-sound/spek/files/02_ftbfs-gcc13.patch b/media-sound/spek/files/02_ftbfs-gcc13.patch
new file mode 100644
index 000000000000..3271d2eb3947
--- /dev/null
+++ b/media-sound/spek/files/02_ftbfs-gcc13.patch
@@ -0,0 +1,10 @@
+Author: Matteo Bini <matteobin@tiepi.it>
+Description: Fix ftbfs with GCC-13
+Forwarded: https://github.com/alexkay/spek/commit/b1600d9926fa434330171cbebb407d2d0ccdcf03
+--- a/tests/perf.cc
++++ b/tests/perf.cc
+@@ -1,3 +1,4 @@
++#include <cstdint>
+ #include <cstdlib>
+ #include <iostream>
+ #include <fstream>
diff --git a/media-sound/spek/files/03_metainfo.patch b/media-sound/spek/files/03_metainfo.patch
new file mode 100644
index 000000000000..f4e57657f36a
--- /dev/null
+++ b/media-sound/spek/files/03_metainfo.patch
@@ -0,0 +1,66 @@
+Author: Nils Fürniß <contact@nalsai.de>
+Description: Add metainfo file
+Forwarded: https://github.com/alexkay/spek/commit/03d7fb6a1a01e7a0adffd0b083fa4c026efb8f84
+--- a/data/Makefile.am
++++ b/data/Makefile.am
+@@ -6,8 +6,15 @@ desktopdir = $(datadir)/applications
+ desktop_in_files = spek.desktop.in
+ desktop_DATA = spek.desktop
+
+-EXTRA_DIST = spek.desktop.in
+-CLEANFILES = spek.desktop
++appdatadir = $(datadir)/metainfo
++appdata_in_files = spek.metainfo.xml.in
++appdata_DATA = spek.metainfo.xml
++
++EXTRA_DIST = spek.desktop.in spek.metainfo.xml.in
++CLEANFILES = spek.desktop spek.metainfo.xml
+
+ spek.desktop: spek.desktop.in $(wildcard $(top_srcdir)/po/*po)
+ $(AM_V_GEN)$(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
++
++spek.metainfo.xml: spek.metainfo.xml.in $(wildcard $(top_srcdir)/po/*po)
++ $(AM_V_GEN)$(MSGFMT) --xml --template $< -d $(top_srcdir)/po -o $@
+--- a/data/spek.metainfo.xml.in
++++ b/data/spek.metainfo.xml.in
+@@ -0,0 +1,40 @@
++<?xml version="1.0" encoding="UTF-8"?>
++<component type="desktop-application">
++ <id>cc.spek.Spek</id>
++ <metadata_license>CC0-1.0</metadata_license>
++ <project_license>GPL-3.0</project_license>
++ <name>Spek</name>
++ <summary>View spectrograms of your audio files</summary>
++ <description>
++ <p>Spek is an acoustic spectrum analyser written in C and C++. It uses FFmpeg libraries for audio decoding and wxWidgets for the GUI.</p>
++ <ul>
++ <li>Supports all popular lossy and lossless audio file formats thanks to the FFmpeg libraries.</li>
++ <li>Ultra-fast signal processing, uses multiple threads to further speed up the analysis.</li>
++ <li>Shows the codec name and the audio signal parameters.</li>
++ <li>Allows to save the spectrogram as an image file.</li>
++ <li>Drag-and-drop support; associates with common audio file formats.</li>
++ <li>Auto-fitting time, frequency and spectral density rulers.</li>
++ <li>Adjustable spectral density range.</li>
++ <li>Translated into 19 languages.</li>
++ </ul>
++ </description>
++ <screenshots>
++ <screenshot type="default">
++ <image>https://raw.githubusercontent.com/alexkay/spek/b3759bbb7d1108b3193394b941eeee982f15b739/web/flac.png</image>
++ </screenshot>
++ </screenshots>
++ <categories>
++ <category>Audio</category>
++ <category>AudioVideo</category>
++ </categories>
++ <url type="homepage">https://www.spek.cc/</url>
++ <url type="bugtracker">https://github.com/alexkay/spek/issues</url>
++ <developer_name>alexkay</developer_name>
++ <content_rating type="oars-1.1" />
++ <launchable type="desktop-id">spek.desktop</launchable>
++ <releases>
++ <release version="0.8.5" date="2023-01-10"/>
++ <release version="0.8.4" date="2022-07-11"/>
++ <release version="0.8.2" date="2016-01-19"/>
++ </releases>
++</component>
diff --git a/media-sound/spek/files/spek-0.8.1-disable-updates.patch b/media-sound/spek/files/spek-0.8.1-disable-updates.patch
deleted file mode 100644
index e035a4c60819..000000000000
--- a/media-sound/spek/files/spek-0.8.1-disable-updates.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- spek-0.8.1/src/spek-preferences.cc
-+++ spek-0.8.1/src/spek-preferences.cc
-@@ -62,7 +62,7 @@
-
- bool SpekPreferences::get_check_update()
- {
-- bool result = true;
-+ bool result = false;
- this->config->Read(wxT("/update/check"), &result);
- return result;
- }
diff --git a/media-sound/spek/files/spek-0.8.3-AR.patch b/media-sound/spek/files/spek-0.8.3-AR.patch
deleted file mode 100644
index be797ba663fc..000000000000
--- a/media-sound/spek/files/spek-0.8.3-AR.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Bug: https://bugs.gentoo.org/754861
-https://github.com/alexkay/spek/pull/198
-
-diff --git a/configure.ac b/configure.ac
-index 3fc451b..b270033 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -5,6 +5,7 @@ AM_INIT_AUTOMAKE([1.11.1 foreign no-dist-gzip dist-xz serial-tests])
- AM_SILENT_RULES([yes])
-
- AC_LANG([C++])
-+AM_PROG_AR
- AC_PROG_CXX
- CXXFLAGS="$CXXFLAGS -std=gnu++11 -Wall -Wextra"
- AC_PROG_CXXCPP
---
-2.26.2
-
diff --git a/media-sound/spek/files/spek-0.8.3-ffmpeg3-1.patch b/media-sound/spek/files/spek-0.8.3-ffmpeg3-1.patch
deleted file mode 100644
index dee0e3ca0f8f..000000000000
--- a/media-sound/spek/files/spek-0.8.3-ffmpeg3-1.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-https://github.com/alexkay/spek/commit/ee8bc49ed4a93a14a933ecb0eebfe424111f8413
-
-Index: spek-0.8.3/src/spek-audio.cc
-===================================================================
---- spek-0.8.3.orig/src/spek-audio.cc
-+++ spek-0.8.3/src/spek-audio.cc
-@@ -202,7 +202,7 @@ AudioFileImpl::AudioFileImpl(
- this->packet.data = nullptr;
- this->packet.size = 0;
- this->offset = 0;
-- this->frame = avcodec_alloc_frame();
-+ this->frame = av_frame_alloc();
- this->buffer_size = 0;
- this->buffer = nullptr;
- this->frames_per_interval = 0;
-@@ -218,7 +218,7 @@ AudioFileImpl::~AudioFileImpl()
- if (this->frame) {
- // TODO: Remove this check after Debian switches to libav 9.
- #if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(54, 28, 0)
-- avcodec_free_frame(&this->frame);
-+ av_frame_free(&this->frame);
- #else
- av_freep(&this->frame);
- #endif
-@@ -258,7 +258,7 @@ int AudioFileImpl::read()
-
- for (;;) {
- while (this->packet.size > 0) {
-- avcodec_get_frame_defaults(this->frame);
-+ av_frame_unref(this->frame);
- auto codec_context = this->format_context->streams[this->audio_stream]->codec;
- int got_frame = 0;
- int len = avcodec_decode_audio4(codec_context, this->frame, &got_frame, &this->packet);
diff --git a/media-sound/spek/files/spek-0.8.3-ffmpeg3.patch b/media-sound/spek/files/spek-0.8.3-ffmpeg3.patch
deleted file mode 100644
index ad82a38c31c5..000000000000
--- a/media-sound/spek/files/spek-0.8.3-ffmpeg3.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-commit 1ef950dcbf89dd8adf816009b54009f487828a45
-Author: Andreas Cadhalpun <Andreas.Cadhalpun@googlemail.com>
-Date: Sun Mar 27 14:19:42 2016 -0700
-
- Replace deprecated FFmpeg API
-
-diff --git a/src/spek-audio.cc b/src/spek-audio.cc
-index b7633bc..21ea7a4 100644
---- a/src/spek-audio.cc
-+++ b/src/spek-audio.cc
-@@ -222,7 +222,7 @@ AudioFileImpl::~AudioFileImpl()
- this->packet.data -= this->offset;
- this->packet.size += this->offset;
- this->offset = 0;
-- av_free_packet(&this->packet);
-+ av_packet_unref(&this->packet);
- }
- if (this->format_context) {
- if (this->audio_stream >= 0) {
-@@ -326,7 +326,7 @@ int AudioFileImpl::read()
- this->packet.data -= this->offset;
- this->packet.size += this->offset;
- this->offset = 0;
-- av_free_packet(&this->packet);
-+ av_packet_unref(&this->packet);
- }
-
- int res = 0;
-@@ -334,7 +334,7 @@ int AudioFileImpl::read()
- if (this->packet.stream_index == this->audio_stream) {
- break;
- }
-- av_free_packet(&this->packet);
-+ av_packet_unref(&this->packet);
- }
- if (res < 0) {
- // End of file or error.
diff --git a/media-sound/spek/files/spek-0.8.3-replace-gnu+11-with-c++11.patch b/media-sound/spek/files/spek-0.8.3-replace-gnu+11-with-c++11.patch
deleted file mode 100644
index 624e969dba4a..000000000000
--- a/media-sound/spek/files/spek-0.8.3-replace-gnu+11-with-c++11.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- spek-0.8.3/configure.ac
-+++ spek-0.8.3/configure.ac
-@@ -6,7 +6,7 @@
-
- AC_LANG([C++])
- AC_PROG_CXX
--CXXFLAGS="$CXXFLAGS -std=gnu++11 -Wall -Wextra"
-+CXXFLAGS="$CXXFLAGS -std=c++11 -Wall -Wextra"
- AC_PROG_CXXCPP
- AC_PROG_RANLIB
- AC_PROG_INSTALL
diff --git a/media-sound/spek/files/spek-0.8.3-stdlib.patch b/media-sound/spek/files/spek-0.8.3-stdlib.patch
deleted file mode 100644
index c0ffa16b4d52..000000000000
--- a/media-sound/spek/files/spek-0.8.3-stdlib.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-https://bugs.gentoo.org/519450
-
---- spek-0.8.3/src/spek-fft.cc
-+++ spek-0.8.3/src/spek-fft.cc
-@@ -17,6 +17,7 @@
- */
-
- #include <math.h>
-+#include <stdlib.h>
-
- #define __STDC_CONSTANT_MACROS
- extern "C" {
---- spek-0.8.3/src/spek-events.cc
-+++ spek-0.8.3/src/spek-events.cc
-@@ -16,6 +16,7 @@
- * along with Spek. If not, see <http://www.gnu.org/licenses/>.
- */
-
-+#include <stdlib.h>
- #include "spek-events.h"
-
- //IMPLEMENT_DYNAMIC_CLASS(SpekHaveSampleEvent, wxEvent)