summaryrefslogtreecommitdiff
path: root/media-sound/spek/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-sound/spek/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-sound/spek/files')
-rw-r--r--media-sound/spek/files/spek-0.8.1-disable-updates.patch11
-rw-r--r--media-sound/spek/files/spek-0.8.3-ffmpeg3-1.patch33
-rw-r--r--media-sound/spek/files/spek-0.8.3-ffmpeg3.patch37
-rw-r--r--media-sound/spek/files/spek-0.8.3-replace-gnu+11-with-c++11.patch11
-rw-r--r--media-sound/spek/files/spek-0.8.3-stdlib.patch22
5 files changed, 114 insertions, 0 deletions
diff --git a/media-sound/spek/files/spek-0.8.1-disable-updates.patch b/media-sound/spek/files/spek-0.8.1-disable-updates.patch
new file mode 100644
index 000000000000..e035a4c60819
--- /dev/null
+++ b/media-sound/spek/files/spek-0.8.1-disable-updates.patch
@@ -0,0 +1,11 @@
+--- spek-0.8.1/src/spek-preferences.cc
++++ spek-0.8.1/src/spek-preferences.cc
+@@ -62,7 +62,7 @@
+
+ bool SpekPreferences::get_check_update()
+ {
+- bool result = true;
++ bool result = false;
+ this->config->Read(wxT("/update/check"), &result);
+ return result;
+ }
diff --git a/media-sound/spek/files/spek-0.8.3-ffmpeg3-1.patch b/media-sound/spek/files/spek-0.8.3-ffmpeg3-1.patch
new file mode 100644
index 000000000000..dee0e3ca0f8f
--- /dev/null
+++ b/media-sound/spek/files/spek-0.8.3-ffmpeg3-1.patch
@@ -0,0 +1,33 @@
+https://github.com/alexkay/spek/commit/ee8bc49ed4a93a14a933ecb0eebfe424111f8413
+
+Index: spek-0.8.3/src/spek-audio.cc
+===================================================================
+--- spek-0.8.3.orig/src/spek-audio.cc
++++ spek-0.8.3/src/spek-audio.cc
+@@ -202,7 +202,7 @@ AudioFileImpl::AudioFileImpl(
+ this->packet.data = nullptr;
+ this->packet.size = 0;
+ this->offset = 0;
+- this->frame = avcodec_alloc_frame();
++ this->frame = av_frame_alloc();
+ this->buffer_size = 0;
+ this->buffer = nullptr;
+ this->frames_per_interval = 0;
+@@ -218,7 +218,7 @@ AudioFileImpl::~AudioFileImpl()
+ if (this->frame) {
+ // TODO: Remove this check after Debian switches to libav 9.
+ #if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(54, 28, 0)
+- avcodec_free_frame(&this->frame);
++ av_frame_free(&this->frame);
+ #else
+ av_freep(&this->frame);
+ #endif
+@@ -258,7 +258,7 @@ int AudioFileImpl::read()
+
+ for (;;) {
+ while (this->packet.size > 0) {
+- avcodec_get_frame_defaults(this->frame);
++ av_frame_unref(this->frame);
+ auto codec_context = this->format_context->streams[this->audio_stream]->codec;
+ int got_frame = 0;
+ int len = avcodec_decode_audio4(codec_context, this->frame, &got_frame, &this->packet);
diff --git a/media-sound/spek/files/spek-0.8.3-ffmpeg3.patch b/media-sound/spek/files/spek-0.8.3-ffmpeg3.patch
new file mode 100644
index 000000000000..ad82a38c31c5
--- /dev/null
+++ b/media-sound/spek/files/spek-0.8.3-ffmpeg3.patch
@@ -0,0 +1,37 @@
+commit 1ef950dcbf89dd8adf816009b54009f487828a45
+Author: Andreas Cadhalpun <Andreas.Cadhalpun@googlemail.com>
+Date: Sun Mar 27 14:19:42 2016 -0700
+
+ Replace deprecated FFmpeg API
+
+diff --git a/src/spek-audio.cc b/src/spek-audio.cc
+index b7633bc..21ea7a4 100644
+--- a/src/spek-audio.cc
++++ b/src/spek-audio.cc
+@@ -222,7 +222,7 @@ AudioFileImpl::~AudioFileImpl()
+ this->packet.data -= this->offset;
+ this->packet.size += this->offset;
+ this->offset = 0;
+- av_free_packet(&this->packet);
++ av_packet_unref(&this->packet);
+ }
+ if (this->format_context) {
+ if (this->audio_stream >= 0) {
+@@ -326,7 +326,7 @@ int AudioFileImpl::read()
+ this->packet.data -= this->offset;
+ this->packet.size += this->offset;
+ this->offset = 0;
+- av_free_packet(&this->packet);
++ av_packet_unref(&this->packet);
+ }
+
+ int res = 0;
+@@ -334,7 +334,7 @@ int AudioFileImpl::read()
+ if (this->packet.stream_index == this->audio_stream) {
+ break;
+ }
+- av_free_packet(&this->packet);
++ av_packet_unref(&this->packet);
+ }
+ if (res < 0) {
+ // End of file or error.
diff --git a/media-sound/spek/files/spek-0.8.3-replace-gnu+11-with-c++11.patch b/media-sound/spek/files/spek-0.8.3-replace-gnu+11-with-c++11.patch
new file mode 100644
index 000000000000..624e969dba4a
--- /dev/null
+++ b/media-sound/spek/files/spek-0.8.3-replace-gnu+11-with-c++11.patch
@@ -0,0 +1,11 @@
+--- spek-0.8.3/configure.ac
++++ spek-0.8.3/configure.ac
+@@ -6,7 +6,7 @@
+
+ AC_LANG([C++])
+ AC_PROG_CXX
+-CXXFLAGS="$CXXFLAGS -std=gnu++11 -Wall -Wextra"
++CXXFLAGS="$CXXFLAGS -std=c++11 -Wall -Wextra"
+ AC_PROG_CXXCPP
+ AC_PROG_RANLIB
+ AC_PROG_INSTALL
diff --git a/media-sound/spek/files/spek-0.8.3-stdlib.patch b/media-sound/spek/files/spek-0.8.3-stdlib.patch
new file mode 100644
index 000000000000..c0ffa16b4d52
--- /dev/null
+++ b/media-sound/spek/files/spek-0.8.3-stdlib.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/519450
+
+--- spek-0.8.3/src/spek-fft.cc
++++ spek-0.8.3/src/spek-fft.cc
+@@ -17,6 +17,7 @@
+ */
+
+ #include <math.h>
++#include <stdlib.h>
+
+ #define __STDC_CONSTANT_MACROS
+ extern "C" {
+--- spek-0.8.3/src/spek-events.cc
++++ spek-0.8.3/src/spek-events.cc
+@@ -16,6 +16,7 @@
+ * along with Spek. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include <stdlib.h>
+ #include "spek-events.h"
+
+ //IMPLEMENT_DYNAMIC_CLASS(SpekHaveSampleEvent, wxEvent)